Closed Bug 1585801 Opened 2 months ago Closed 2 months ago

Crash in [@ core::result::unwrap_failed<T> | webrender::render_backend::RenderBackend::run]

Categories

(Core :: Graphics: WebRender, defect, P2, critical)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: marcia, Assigned: kris)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(1 file)

This bug is for crash report bp-fb9db9ae-c989-40dc-9759-617290190930.

Seen while looking at nightly crash stats - crashes started in 20190927215713: https://bit.ly/2nMFt8e.

Moz crash reason: called Result::unwrap() on an Err value: Os { code: 5, kind: PermissionDenied, message: "Zugriff verweigert" }

Top 10 frames of crashing thread:

0 xul.dll GeckoCrash toolkit/xre/nsAppRunner.cpp:5117
1 xul.dll static void gkrust_shared::panic_hook toolkit/library/rust/shared/lib.rs:248
2 xul.dll static void core::ops::function::Fn::call<fn src/libcore/ops/function.rs:69
3 xul.dll static void std::panicking::rust_panic_with_hook src/libstd/panicking.rs:481
4 xul.dll static void std::panicking::continue_panic_fmt src/libstd/panicking.rs:384
5 xul.dll static void std::panicking::rust_begin_panic src/libstd/panicking.rs:311
6 xul.dll static void core::panicking::panic_fmt src/libcore/panicking.rs:85
7 xul.dll static <NoType> core::result::unwrap_failed<std::io::error::Error> src/libcore/macros.rs:18
8 xul.dll static void webrender::render_backend::RenderBackend::run gfx/wr/webrender/src/render_backend.rs
9  @0x1f1fdc94c6f 

Jeff, could this be related to: Bug 1582645

Flags: needinfo?(jmuizelaar)
Blocks: wr-71
Priority: -- → P2

The stacks from this crash are not really very useful because we don't know which unwrap is failing. See https://github.com/rust-lang/rust/issues/63105 for why and a possible solution.

Flags: needinfo?(jmuizelaar)

It is notable that we're unwraping this result though:
called Result::unwrap() on an Err value: Os { code: 5, kind: PermissionDenied, message: "Access is denied." }

Perhaps that can help us narrow down where the crash is happening.

Flags: needinfo?(jmuizelaar)

I believe this was caused by bug 1582565

Depends on: 1582565
Flags: needinfo?(jmuizelaar)
Assignee: nobody → ktaeleman

:kris, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(ktaeleman)

Hello Kris - if this fix is approved, can we get it checked in? Thanks.

d

Flags: needinfo?(ktaeleman)
Regressed by: 1582565

Yes, @jrmuizel, could you land https://phabricator.services.mozilla.com/D48999?

Flags: needinfo?(jmuizelaar)
Pushed by jmuizelaar@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5506d1803e15
Fixing crash when folder is not writable and refactored logic. r=jrmuizel
Flags: needinfo?(jmuizelaar)
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

Is there something here that could be covered by the manual QA, some steps maybe? Thank you!

Flags: needinfo?(ktaeleman)

This is a nightly only development feature.
Pressing ctrl + shift + 5 toggles logging of transactions sent to webrender into a file in the workspace folder of firefox. (wr-log-[date].log)

The issue here was that when this path was not writeable (ex. Installation in Program Files) the application would crash and keep crashing at startup as the preference flag enabling the feature was not cleared.

In the patch for this fix, the implementation was changed to only use the shortcut and the preference was removed. Extra safeguards were also put in place that handle not being able to write to the file.

Flags: needinfo?(ktaeleman)

(In reply to Kris Taeleman (:kris/kris) from comment #13)

This is a nightly only development feature.

Thank you for your time, since this is Nightly only I will not set the qe+ as part of 71 Beta bug verification!

You need to log in before you can comment on or make changes to this bug.