Closed Bug 1585907 Opened 4 months ago Closed 2 months ago

Announce when Reader View is available for screen reader users

Categories

(Toolkit :: Reader Mode, enhancement)

enhancement
Not set

Tracking

()

RESOLVED WONTFIX
mozilla71
Tracking Status
firefox71 + wontfix

People

(Reporter: Jamie, Assigned: Jamie, NeedInfo)

References

Details

(Keywords: access)

Attachments

(2 files, 1 obsolete file)

While the availability of Reader View is somewhat noticeable visually, a screen reader user won't be aware of this unless they explicitly explore the toolbar. In bug 1425541, I exposed a "reader" accessibility object attribute to allow screen readers to access this information programmatically. However, this was never actually used by any screen readers. Supporting this would require screen readers to implement a change specific to Firefox, which is not ideal.

In bug 1425541, I added a function to announce a message for screen reader users for cases like these. I propose to remove the reader object attribute and instead announce a message using this new function.

See Also: → 1425541

This reverts bug 1425541.
This was intended to make it easy for accessibility clients to retrieve the Reader View state programmatically.
However, it was never actually used by any clients.

While the availability of Reader View is somewhat noticeable visually, a screen reader user won't be aware of this unless they explicitly explore the toolbar.

No longer blocks: 1576509
Depends on: 1576509
Attachment #9098462 - Attachment description: Bug 1585907 part 2: Announce when Reader View is available for screen reader users. → Bug 1585907 part 3: Announce when Reader View is available for screen reader users.
Pushed by jteh@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3ccd96b2fd41
part 1: Remove exposure of the "reader" accessibility object attribute. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/ecdf703ca175
part 2: Allow A11yUtils.announce to take a Fluent id. r=Gijs
https://hg.mozilla.org/integration/autoland/rev/4c9e50d055ea
part 3: Announce when Reader View is available for screen reader users. r=Gijs,fluent-reviewers

I confirm that it works.

It seems the notification is send multiple times, I've for the same page receive 3 times the notifications. I'm using Orca master on Debian 9 "Stretch". Are you aware of this?

On this page for example: https://www.clubic.com/video-streaming/netflix-svod/actualite-870467-cofondateur-netflix-pourquoi-publicite.html
If you move to the next header multiple times you'll hear reader view available.

Otherwise, the notification is send in English whereas I'm in French.

Thanks for your work.

Best regards.

(In reply to Alex ARNAUD from comment #6)

It seems the notification is send multiple times, I've for the same page receive 3 times the notifications. I'm using Orca master on Debian 9 "Stretch". Are you aware of this?

It only gets fired once on Windows. Please file a new Linux-specific bug for this.

Otherwise, the notification is send in English whereas I'm in French.

This is due to no localization in French yet available for this. I'm on a German system, and also hear it in English for now. Once localizers update the strings for this, after some update in the future, it will change to your language.

Hi guys,

Thanks for your job. I am rather surprised about the priority of this bug but... well.

As the "rader view" seems available on many pages, it generates a message whenever I press Enter. So I think it is polluting our ears. I wonder if we could not:

  • either emitting the message only if the mode is not present
  • either emitting it when the user presses the shortcuts, as it is a feedback to his request
  • or having a setting in the preferences menu, to have or not this message, in accessibility tab.

Many thanks

regards

I have to agree with the last commend. Reader view availability may be important for some people but for me it is horribly distracting to hear it with almost every page and adds no real. value. It was frustrating enough that for now I've disabled it completely from about:config.

The reason we added this is that many users are not even aware that Firefox has Reader View. While a sighted user might glance at the toolbar and see the icon is present, a screen reader user will rarely be aware of it unless they actively explore the toolbar (which they might not happen to do while a page that supports this is loaded). Note that mobile browsers (e.g. Safari and Firefox on iOS) have done this for some time. Reader View can be very useful for reading articles, etc. This is true for everyone, but especially for screen reader users, since it removes a lot of clutter, which tends to reduce efficiency for screen reader users more than most.

That said, it is clearly "hurting" you as users here, so we need to figure out how to deal with this. I'd be grateful if you could answer a few questions:

  1. Were you already aware of Reader View?
  2. Do you find it useful?
  3. Do you feel that Reader View is available on pages where it shouldn't be; e.g. pages that aren't articles or other long-form reading?
  4. Do you prefer to just try the Reader View command on demand and see if it works?
  5. If you do find it useful, imagine you didn't know about it. Do you think it's useful to have Firefox tell you about it so you can be aware of it?
  6. If this were a setting, would you be happy to have it enabled by default (so users can learn about it) but disable it to suit your own preferences? Or do you really think this should be removed?
Flags: needinfo?(wulfryk1)
Flags: needinfo?(jpmengual)

Hi Jamie,

(In reply to James Teh [:Jamie] from comment #10)

The reason we added this is that many users are not even aware that Firefox has Reader View. While a sighted user might glance at the toolbar and see the icon is present, a screen reader user will rarely be aware of it unless they actively explore the toolbar (which they might not happen to do while a page that supports this is loaded). Note that mobile browsers (e.g. Safari and Firefox on iOS) have done this for some time. Reader View can be very useful for reading articles, etc. This is true for everyone, but especially for screen reader users, since it removes a lot of clutter, which tends to reduce efficiency for screen reader users more than most.

I understand this point, and really think you are right with highlighting this feature. To do tis without polluting the user, could no we anonce it at the opening of Firefox? The notification would be heard only at opening Firefox, o let user know this exists.

That said, it is clearly "hurting" you as users here, so we need to figure out how to deal with this. I'd be grateful if you could answer a few questions:

  1. Were you already aware of Reader View?

Yes, but I I did not think it had an interest for a screen reader user. I think it was rather for low sightd persons to get a better magnification. I will try it myself then

  1. Do you find it useful?

Yes, sure. I think I will try it more often, now I know it interest for blind users, but I am sure it has usecases.

  1. Do you feel that Reader View is available on pages where it shouldn't be; e.g. pages that aren't articles or other long-form reading?

hmmm yes. For example, the view seems available on Dolibarr home page, while on this page, there is mainly dashboard, menus etc. However, may make sense for a low-sighted person

  1. Do you prefer to just try the Reader View command on demand and see if it works?

Yes

  1. If you do find it useful, imagine you didn't know about it. Do you think it's useful to have Firefox tell you about it so you can be aware of it?

Yes, but once only.

  1. If this were a setting, would you be happy to have it enabled by default (so users can learn about it) but disable it to suit your own preferences? Or do you really think this should be removed?

Your proposal seems good. We enable it by default to ensure any user is aware of the option, but once done, he can disable it to use it without pollution. I wonder if Firefox does not do it for privacy stuff or other features it wants the user to be aware of.

Best regards

I am aware of reader view, and as a blind web browser, I do find it useful. I think just placing the option in the toolbar or letting someone try the reader view toggle is sufficient. It's already out there in enough browsers that I think blind people who are interested in it and have heard about it will look for it. Maybe a popup could be tossed up to let people know this feature is now in Firefox and how to toggle it on and then a user could dismiss that and never see it again.

(In reply to James Teh [:Jamie] from comment #10)

The reason we added this is that many users are not even aware that Firefox has Reader View. While a sighted user might glance at the toolbar and see the icon is present, a screen reader user will rarely be aware of it unless they actively explore the toolbar (which they might not happen to do while a page that supports this is loaded). Note that mobile browsers (e.g. Safari and Firefox on iOS) have done this for some time.

How it is signaled to screen reader users there? I am not on iOS.

That said, it is clearly "hurting" you as users here, so we need to figure out how to deal with this. I'd be grateful if you could answer a few questions:

  1. Were you already aware of Reader View?

Yes

  1. Do you find it useful?

No, i prefer to configure my add blocker and noScript to remove unneeded parts of the page.

  1. Do you feel that Reader View is available on pages where it shouldn't be; e.g. pages that aren't articles or other long-form reading?

No idea, I haven't payed attention.

  1. If you do find it useful, imagine you didn't know about it. Do you think it's useful to have Firefox tell you about it so you can be aware of it?

Yes but giving this information once is in my opinion sufficient.

  1. If this were a setting, would you be happy to have it enabled by default (so users can learn about it) but disable it to suit your own preferences? Or do you really think this should be removed?

Yes, as long as disabling is clearly documented.

Flags: needinfo?(wulfryk1)
QA Whiteboard: [qa-71b-p2]

Ryan, can we arrange to get this backed out of beta? Is there a process I should follow? We need only back out part 3; the other two parts have no user visible impact and one of them is needed by something else. This is causing some user pain and we don't want it to continue hurting beta users and/or graduating to release as-is. I'll file a follow-up to improve this and/or disable it on nightly.

Flags: needinfo?(ryanvm)
Flags: needinfo?(jteh)
Flags: needinfo?(ryanvm)
Flags: needinfo?(jteh)

Pascal, can we stop tracking this for 71? It's been backed out of 71 and I do not intend to pursue it for 71; we'll decide what to do for 72+.

Flags: needinfo?(pascalc)

(In reply to James Teh [:Jamie] from comment #14)

I'll file a follow-up to improve this and/or disable it on nightly.

Ni for this. :-)

Flags: needinfo?(jteh)
Regressions: 1593900
Flags: needinfo?(jteh)

Backed out changeset 4c9e50d055ea (Bug 1585907) per developer's request

Backout: https://hg.mozilla.org/integration/autoland/rev/21aecc366f78ddc3732c46e48b25b0fcba20b931

Status: RESOLVED → REOPENED
Flags: needinfo?(jteh)
Resolution: FIXED → ---
Status: REOPENED → RESOLVED
Closed: 3 months ago2 months ago
Flags: needinfo?(jteh)
Resolution: --- → WONTFIX
Attachment #9098462 - Attachment is obsolete: true
You need to log in before you can comment on or make changes to this bug.