Closed Bug 1585946 Opened 2 months ago Closed Last month

Perma webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-construction.https.html | X Creating a node before loading a module should throw. threw "ReferenceError" instead of InvalidStateError. when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: Web Audio, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + verified

People

(Reporter: rmaries, Assigned: aryx)

References

(Depends on 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception&classifiedState=unclassified&revision=7e2691457a0a60832980608b33e39a6556b9e77c&selectedJob=269586363

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=269586363&repo=try&lineNumber=20329

[task 2019-10-03T11:19:49.728Z] 11:19:49 INFO - TEST-OK | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-channel-count.https.html | took 1353ms
[task 2019-10-03T11:19:49.728Z] 11:19:49 INFO - TEST-START | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-construction.https.html
[task 2019-10-03T11:19:49.732Z] 11:19:49 INFO - Closing window 43
[task 2019-10-03T11:19:49.773Z] 11:19:49 INFO - PID 26049 | -----------------------------------------------------
[task 2019-10-03T11:19:49.782Z] 11:19:49 INFO - PID 26049 | Suppressions used:
[task 2019-10-03T11:19:49.782Z] 11:19:49 INFO - PID 26049 | count bytes template
[task 2019-10-03T11:19:49.783Z] 11:19:49 INFO - PID 26049 | 26 800 nsComponentManagerImpl
[task 2019-10-03T11:19:49.784Z] 11:19:49 INFO - PID 26049 | 611 17713 libfontconfig.so
[task 2019-10-03T11:19:49.785Z] 11:19:49 INFO - PID 26049 | 1 29 libglib-2.0.so
[task 2019-10-03T11:19:49.785Z] 11:19:49 INFO - PID 26049 | -----------------------------------------------------
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO -
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-construction.https.html | # AUDIT TASK RUNNER STARTED.
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO - TEST-PASS | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-construction.https.html | > [construction-before-module-loading]
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO - TEST-UNEXPECTED-FAIL | /webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-construction.https.html | X Creating a node before loading a module should throw. threw "ReferenceError" instead of InvalidStateError. - assert_true: expected true got false
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO - _logFailed/<@https://web-platform.test:8443/webaudio/resources/audit.js:50:18
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO - Test.prototype.step@https://web-platform.test:8443/resources/testharness.js:1908:25
[task 2019-10-03T11:19:50.888Z] 11:19:50 INFO - test@https://web-platform.test:8443/resources/testharness.js:544:30
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - _logFailed@https://web-platform.test:8443/webaudio/resources/audit.js:49:9
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - _finalize@https://web-platform.test:8443/webaudio/resources/audit.js:215:19
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - _assert@https://web-platform.test:8443/webaudio/resources/audit.js:228:12
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - throw@https://web-platform.test:8443/webaudio/resources/audit.js:337:19
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - @https://web-platform.test:8443/webaudio/the-audio-api/the-audioworklet-interface/audioworkletnode-construction.https.html:26:18
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - run@https://web-platform.test:8443/webaudio/resources/audit.js:1195:14
[task 2019-10-03T11:19:50.889Z] 11:19:50 INFO - _runNextTask@https://web-platform.test:8443/webaudio/resources/audit.js:1275:67

James, I think bug 1584570, https://hg.mozilla.org/mozilla-central/rev/99895cb320b0 could be the culprit. Coud you take a look?

Flags: needinfo?(james)
Regressed by: 1584570

These tests are breaking the supposed invariant that you return the same subtests on pass and fail. So on beta we get test names that simply don't exist on nightly, and so the metadata update optimises out the corresponding metadata.

I think there's going to have to be a solution for this kind of thing in the metadata, but really it would be good to fix the test to use the harness in vaugely the correct way. ni karlt for that.

In the interim feel free to revert the corresponding metadata changes on beta.

Flags: needinfo?(james) → needinfo?(karlt)

https://phabricator.services.mozilla.com/D47025 is one part of changes required to make test names consistent.

Happy to fix other parts if that approach is accepted.
https://github.com/web-platform-tests/wpt/issues/10201

Flags: needinfo?(karlt)
Depends on: 1569559
Priority: -- → P2

(In reply to Karl Tomlinson (back Oct 14 :karlt) from comment #3)

https://phabricator.services.mozilla.com/D47025 is one part of changes required to make test names consistent.

Happy to fix other parts if that approach is accepted.
https://github.com/web-platform-tests/wpt/issues/10201

Hi Karl, I saw the above landed (phab patch), is there an update here?

Flags: needinfo?(karlt)

The annotations got removed in bug 1584570 (due an issue with the tool which
updates the annotations). All of these annotations had been added before, most
in bug 1583496.

The test fail because AudioWorklet is not enabled on these trees.

Assignee: nobody → aryx.bugmail
Status: NEW → ASSIGNED
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/c9ea9966d4cd
Set audioworkletnode tests to fail on beta and release. r=jgraham
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → mozilla71

(In reply to Andreea Pavel [:apavel] from comment #6)

(In reply to Karl Tomlinson (back Oct 14 :karlt) from comment #3)

https://phabricator.services.mozilla.com/D47025 is one part of changes required to make test names consistent.

Hi Karl, I saw the above landed (phab patch), is there an update here?

It has not landed. It is still waiting for review.

Flags: needinfo?(karlt)

(In reply to Karl Tomlinson (:karlt) from comment #14)

(In reply to Andreea Pavel [:apavel] from comment #6)

(In reply to Karl Tomlinson (back Oct 14 :karlt) from comment #3)

https://phabricator.services.mozilla.com/D47025 is one part of changes required to make test names consistent.

Hi Karl, I saw the above landed (phab patch), is there an update here?

It has not landed. It is still waiting for review.

Sorry, this is misleading https://lando.services.mozilla.com/D47025/

Whiteboard: [checkin-needed][checkin-needed-beta]
Whiteboard: [checkin-needed][checkin-needed-beta] → [checkin-needed]
Whiteboard: [checkin-needed]
You need to log in before you can comment on or make changes to this bug.