Closed Bug 1586005 Opened 6 months ago Closed 5 months ago

Iframe gets reloaded from cached URL, despite DOM showing new URL; the view gets updated correctly with new fetched document.

Categories

(Core :: DOM: Navigation, defect)

69 Branch
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: d.mathis, Unassigned)

References

(Depends on 1 open bug)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.90 Safari/537.36

Steps to reproduce:

I have a page which has an embeded iframe. The iframe always points to the same URL, only the params change. I use the params to display different content.

I then reload the page, it does not always happen - might take multiple reloads.

Using Firefox 69.0.1 (64-bit) on Windows 10.

Actual results:

On reload of the page, I can see in developer tools that the DOM has the new iframe src (the main page gets correctly loaded).

Then the iframe itself gets loaded from the cached URL, it does not use the URL which is in the actual src. I can see this in Network tab, and I can also see it on the server getting the request, that I get previous params.

It then shows the freshly fetched (from wrong url) iframe correctly, at least that works - and it does not show a cached version.

Expected results:

It should use the src given in the actual html, and not the cached from a previous load.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → DOM: Core & HTML
Product: Firefox → Core

What does work is setting the src to "about:blank"; and then set it through Javascript to the new URL.
As described here: https://bugzilla.mozilla.org/show_bug.cgi?id=363840#c28

It looks like a duplicate of bug 279048.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 279048

Wait, how can this be a duplicate of a fixed bug if it's still happening?

It doesn't sound like the page in question uses a dynamically inserted iframe; the source HTML of the page is just changing, right?

In general, the user expectation is "reload what I see", hence the observed behavior of doing a reload in the iframe as if reload() were called on it, as opposed to loading the new url. A forced reload (shift-reload) will completely reload everything from scratch, I believe, if the idea is to have something in development to test updates.

Status: RESOLVED → REOPENED
Depends on: 356558
Ever confirmed: true
Resolution: DUPLICATE → ---

Does not happen anymore with Firefox 69.0.3 (64-bit) on Windows 10.
Will monitor this, if it happens again will comment.

Component: DOM: Core & HTML → Document Navigation

Please reopen if this happens again.

Status: REOPENED → RESOLVED
Closed: 6 months ago5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.