Closed Bug 1586024 Opened 1 year ago Closed 1 year ago

Megabar's Focused & Collapsed state is inconsistent on Windows

Categories

(Firefox :: Address Bar, defect, P3)

Desktop
Windows
defect
Points:
5

Tracking

()

RESOLVED INVALID

People

(Reporter: harry, Unassigned)

References

(Regression)

Details

Bug 1579004 seems to be broken on Windows. The Megabar should enter the Focused & Collapsed state for any clicks on browser UI. This is the case on Mac and Linux. On Windows, we are only entering Focused & Collapsed when clicking on the active tab: clicks on the empty toolbar or tab bar are not collapsing the megabar.

Priority: -- → P2
Blocks: 1586523
Assignee: nobody → dao+bmo
Status: NEW → ASSIGNED
Iteration: --- → 71.4 - Oct 14 - 20
Points: --- → 3

I believe this is due to how window dragging works on Windows. Areas that are reserved for dragging don't get mouse events. Jim, can you confirm? Is there any way we can detect these mousedown events in the frontend?

Points: 3 → ---
Flags: needinfo?(jmathies)
Assignee: dao+bmo → nobody
Status: ASSIGNED → NEW
Iteration: 71.4 - Oct 14 - 20 → ---
Depends on: 1589826
Priority: P2 → P3

This is probably tied to that mouse handling code in nsWindow that treats open space in a unique way. I can try to find someone to take a look. Could be a while though.

https://searchfox.org/mozilla-central/search?q=mDraggableRegion&redirect=false

Flags: needinfo?(jmathies)
Priority: P3 → P2

back to P3 since we're fixing bug 1589826

Priority: P2 → P3
Points: --- → 5

Bug 1589826 removes the Focused & Collapsed state, making this bug invalid.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.