Closed Bug 1586090 Opened 1 year ago Closed 11 months ago

Make sign up for breach alert easier from Protection report

Categories

(Firefox :: Protections UI, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox70 + verified
firefox71 --- verified
firefox72 --- verified

People

(Reporter: chsiang, Assigned: ewright)

References

Details

(Whiteboard: [rca - Ambiguous Design])

Attachments

(1 file)

Current flow:

FxA team has implemented the oauth flow so an existing account users should just go through that flow and be able to sign up with one click

Erica, could you take a look and see how fast we could implement this?

Flags: needinfo?(ewright)
Priority: P1 → --
Whiteboard: [protection-report][skyline]
Whiteboard: [protection-report][skyline] → [protection-report]

Is this the flow that the FxA team had in mind for this: https://github.com/mozilla/fxa/pull/1150 ?

Flags: needinfo?(stomlinson)
Flags: needinfo?(adavis)
Depends on: 1578632

(In reply to Vlad Filippov (:vladikoff) from comment #2)

Is this the flow that the FxA team had in mind for this: https://github.com/mozilla/fxa/pull/1150 ?

It's a valid use of prompt=none. Note, monitor/the browser will need to handle the errors listed here [1] to ensure a smooth flow.

[1] - https://github.com/mozilla/fxa/blob/master/packages/fxa-auth-server/fxa-oauth-server/docs/prompt-none.md#handling-errors

Flags: needinfo?(stomlinson)

There has been some confusion around the ask in this bug. It is that if the user is signed in with the browser, they should not land on the landing page on monitor, but instead should see the FXA login screen with their email already populated, then be redirected to monitor after logging in. This currently happens if the user is not subscribed to monitor, but this does not happen correctly if the user is subscribed to monitor.
This is an easy fix - coming up.

Flags: needinfo?(ewright)
Attachment #9101340 - Attachment description: Bug 1586090 - Direct signed-in and subscribed users to fxa on monitor page.' → Bug 1586090 - Direct signed-in and subscribed users to fxa on monitor page.
Priority: -- → P1
Whiteboard: [protection-report] → [protection-report][skyline]
Assignee: nobody → ewright
Status: NEW → ASSIGNED
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/5287a548f20b
Direct signed-in and subscribed users to fxa on monitor page. r=MattN

Comment on attachment 9101340 [details]
Bug 1586090 - Direct signed-in and subscribed users to fxa on monitor page.

Beta/Release Uplift Approval Request

  • User impact if declined: Users who are both signed in and subscribed to monitor need to go through an extra step of arriving on the monitor landing page, and signing in from there. Instead of being directed to the FXA auth page then redirected to their personal monitor report.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small JS change, reusing and moving code, nothing new. This flow has already been implemented if the user is signed in and not subscribed to monitor.
  • String changes made/needed: none
Attachment #9101340 - Flags: approval-mozilla-release?
No longer depends on: 1578632
Flags: needinfo?(adavis)
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Erica, Johann, does this need to be in 70? It's aimed at the 70.1 dot release, right?

Flags: needinfo?(jhofmann)
Flags: needinfo?(ewright)

(In reply to Liz Henry (:lizzard) from comment #9)

Erica, Johann, does this need to be in 70? It's aimed at the 70.1 dot release, right?

Yes please, if it can make it into the 70.1 release that would be good.

Flags: needinfo?(jhofmann)
Flags: needinfo?(ewright)

Can you suggest some way for QA to verify the fix in beta?

Flags: needinfo?(ewright)

(In reply to Liz Henry (:lizzard) from comment #11)

Can you suggest some way for QA to verify the fix in beta?

Yes!

  • Sign in to the browser and sign in to monitor
  • Visit the protection report
  • After seeing the monitor card load with your login information, follow the link at "View full report on Firefox Monitor"
  • the link should lead to account verification at accounts.firefox.com, then redirect to "https://monitor.firefox.com/user/dashboard"

Before this fix

Flags: needinfo?(ewright)
QA Whiteboard: [qa-triaged]

I verified the fix using latest Nightly 72.0a1 and Firefox 71.0b4 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+

Comment on attachment 9101340 [details]
Bug 1586090 - Direct signed-in and subscribed users to fxa on monitor page.

Tweak to signin flow, verified in nightly. OK for uplift to m-r for 70.1.

Attachment #9101340 - Flags: approval-mozilla-release? → approval-mozilla-release+

I verified the fix on Firefox 70.0.1 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The issue is not reproducing anymore.

This bug has been identified as part of a pilot on determining root causes of blocking and dot release drivers.

It needs a root-cause set for it. Please see the list at https://docs.google.com/document/d/1FFEGsmoU8T0N8R9kk-MXWptOPtXXXRRIe4vQo3_HgMw/.

Add the root cause as a whiteboard tag in the form [rca - <cause> ] and remove the rca-needed keyword.

If you have questions, please contact :tmaity.

Keywords: rca-needed
Keywords: rca-needed
Whiteboard: [protection-report][skyline] → [rca - Ambiguous Design]
You need to log in before you can comment on or make changes to this bug.