Closed Bug 1586238 Opened 3 years ago Closed 3 years ago

Perma bustage on /builds/worker/workspace/build/src/docshell/base/CanonicalBrowsingContext.cpp when Gecko 71 merges to Beta on 2019-10-14

Categories

(Core :: DOM: Navigation, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla71
Fission Milestone M4
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: cbrindusan, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Central as beta:
https://treeherder.mozilla.org/#/jobs?repo=try&resultStatus=testfailed%2Cbusted%2Cexception%2Cretry%2Cusercancel%2Crunnable&revision=d3a8c1fb95abeed2ddfe694f1f15dac5d7435db9&selectedJob=269751462

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=269751462&repo=try&lineNumber=32292

[task 2019-10-04T10:26:41.493Z] 10:26:41 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/accessible/atk'
[task 2019-10-04T10:26:41.555Z] 10:26:41 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/docshell/shistory'
[task 2019-10-04T10:26:41.558Z] 10:26:41 INFO - /builds/worker/fetches/sccache/sccache /builds/worker/fetches/clang/bin/clang++ -o Unified_cpp_docshell_shistory0.o -c -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/docshell/shistory -I/builds/worker/workspace/build/src/obj-firefox/docshell/shistory -I/builds/worker/workspace/build/src/docshell/base -I/builds/worker/workspace/build/src/dom/base -I/builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -I/builds/worker/workspace/build/src/ipc/chromium/src -I/builds/worker/workspace/build/src/ipc/glue -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -fno-common -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-error=tautological-type-limit-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -fno-aligned-new -fsanitize=bool,bounds,vla-bound -fno-sanitize-recover=bool,bounds,vla-bound -fsanitize-blacklist=/builds/worker/workspace/build/src/obj-firefox/ubsan_blacklist.txt -fsanitize=address -fcrash-diagnostics-dir=/builds/worker/artifacts -U_FORTIFY_SOURCE -fno-common -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O2 -gline-tables-only -fno-omit-frame-pointer -funwind-tables -Werror -Wno-error=shadow -MD -MP -MF .deps/Unified_cpp_docshell_shistory0.o.pp Unified_cpp_docshell_shistory0.cpp
[task 2019-10-04T10:26:41.558Z] 10:26:41 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/docshell/shistory'
[task 2019-10-04T10:26:41.579Z] 10:26:41 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/accessible/xul'
[task 2019-10-04T10:26:41.579Z] 10:26:41 INFO - mkdir -p '.deps/'
[task 2019-10-04T10:26:41.579Z] 10:26:41 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/accessible/xul'
[task 2019-10-04T10:26:41.586Z] 10:26:41 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/accessible/xul'
[task 2019-10-04T10:26:41.587Z] 10:26:41 INFO - accessible/xul/Unified_cpp_accessible_xul0.o
[task 2019-10-04T10:26:41.587Z] 10:26:41 INFO - make[4]: Leaving directory '/builds/worker/workspace/build/src/obj-firefox/accessible/xul'
[task 2019-10-04T10:26:42.594Z] 10:26:42 INFO - make[4]: Entering directory '/builds/worker/workspace/build/src/obj-firefox/docshell/base'
[task 2019-10-04T10:26:42.594Z] 10:26:42 INFO - /builds/worker/fetches/sccache/sccache /builds/worker/fetches/clang/bin/clang++ -o Unified_cpp_docshell_base0.o -c -I/builds/worker/workspace/build/src/obj-firefox/dist/stl_wrappers -I/builds/worker/workspace/build/src/obj-firefox/dist/system_wrappers -include /builds/worker/workspace/build/src/config/gcc_hidden.h -DNDEBUG=1 -DTRIMMED=1 -DOS_POSIX=1 -DOS_LINUX=1 -DSTATIC_EXPORTABLE_JS_API -DMOZ_HAS_MOZGLUE -DMOZILLA_INTERNAL_API -DIMPL_LIBXUL -I/builds/worker/workspace/build/src/docshell/base -I/builds/worker/workspace/build/src/obj-firefox/docshell/base -I/builds/worker/workspace/build/src/obj-firefox/ipc/ipdl/_ipdlheaders -I/builds/worker/workspace/build/src/ipc/chromium/src -I/builds/worker/workspace/build/src/ipc/glue -I/builds/worker/workspace/build/src/docshell/shistory -I/builds/worker/workspace/build/src/dom/base -I/builds/worker/workspace/build/src/dom/bindings -I/builds/worker/workspace/build/src/js/xpconnect/src -I/builds/worker/workspace/build/src/layout/base -I/builds/worker/workspace/build/src/layout/generic -I/builds/worker/workspace/build/src/layout/style -I/builds/worker/workspace/build/src/layout/xul -I/builds/worker/workspace/build/src/netwerk/base -I/builds/worker/workspace/build/src/netwerk/protocol/viewsource -I/builds/worker/workspace/build/src/toolkit/components/browser -I/builds/worker/workspace/build/src/toolkit/components/find -I/builds/worker/workspace/build/src/tools/profiler -I/builds/worker/workspace/build/src/obj-firefox/dist/include -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nspr -I/builds/worker/workspace/build/src/obj-firefox/dist/include/nss -fPIC -DMOZILLA_CLIENT -include /builds/worker/workspace/build/src/obj-firefox/mozilla-config.h -Qunused-arguments -U_FORTIFY_SOURCE -fno-common -Qunused-arguments -Wall -Wbitfield-enum-conversion -Wempty-body -Wignored-qualifiers -Woverloaded-virtual -Wpointer-arith -Wshadow-field-in-constructor-modified -Wsign-compare -Wtype-limits -Wunreachable-code -Wunreachable-code-return -Wwrite-strings -Wno-invalid-offsetof -Wclass-varargs -Wfloat-overflow-conversion -Wfloat-zero-conversion -Wloop-analysis -Wc++1z-compat -Wc++2a-compat -Wcomma -Wimplicit-fallthrough -Werror=non-literal-null-conversion -Wstring-conversion -Wtautological-overlap-compare -Wtautological-unsigned-enum-zero-compare -Wtautological-unsigned-zero-compare -Wno-error=tautological-type-limit-compare -Wno-inline-new-delete -Wno-error=deprecated-declarations -Wno-error=array-bounds -Wno-error=backend-plugin -Wno-error=return-std-move -Wno-error=atomic-alignment -Wformat -Wformat-security -Wno-gnu-zero-variadic-macro-arguments -Wno-unknown-warning-option -Wno-return-type-c-linkage -D_GLIBCXX_USE_CXX11_ABI=0 -fno-sized-deallocation -fno-aligned-new -fsanitize=bool,bounds,vla-bound -fno-sanitize-recover=bool,bounds,vla-bound -fsanitize-blacklist=/builds/worker/workspace/build/src/obj-firefox/ubsan_blacklist.txt -fsanitize=address -fcrash-diagnostics-dir=/builds/worker/artifacts -U_FORTIFY_SOURCE -fno-common -fno-exceptions -fno-strict-aliasing -fno-rtti -ffunction-sections -fdata-sections -fno-exceptions -fno-math-errno -pthread -pipe -g -Xclang -load -Xclang /builds/worker/workspace/build/src/obj-firefox/build/clang-plugin/libclang-plugin.so -Xclang -add-plugin -Xclang moz-check -O2 -gline-tables-only -fno-omit-frame-pointer -funwind-tables -Werror -Wno-error=shadow -MD -MP -MF .deps/Unified_cpp_docshell_base0.o.pp Unified_cpp_docshell_base0.cpp
[task 2019-10-04T10:26:42.594Z] 10:26:42 INFO - In file included from Unified_cpp_docshell_base0.cpp:20:
[task 2019-10-04T10:26:42.594Z] 10:26:42 ERROR - /builds/worker/workspace/build/src/docshell/base/CanonicalBrowsingContext.cpp:272:35: error: lambda capture 'inFlightProcessId' is not used [-Werror,-Wunused-lambda-capture]

Nika, this seems to be caused by the changes in Bug 1576714, could you please take a look at it?

Flags: needinfo?(nika)

Closing this as bug 1576714 got backed out. This issue will have to be resolved with the relanding.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla71
Flags: needinfo?(nika)

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.