Closed Bug 1586435 Opened 2 years ago Closed 2 years ago

Crash in [@ mozilla::detail::HashTable<T>::destroyTable | js::XDRIncrementalEncoder::~XDRIncrementalEncoder]

Categories

(Core :: JavaScript Engine, defect)

Desktop
Windows 10
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1585874
Tracking Status
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: marcia, Unassigned)

References

Details

(Keywords: crash, regression)

Crash Data

This bug is for crash report bp-9407ab7c-145c-4f64-8d08-73f670191004.

In the same regression range as Bug 1586433, but not sure if it is the same issue: https://bit.ly/2MdpxE6

Top 10 frames of crashing thread:

0 xul.dll static void mozilla::detail::HashTable<mozilla::HashMapEntry<js::HeapPtr<JSAtom*>, unsigned int>, mozilla::HashMap<js::HeapPtr<JSAtom*>, unsigned int, mozilla::DefaultHasher<js::HeapPtr<JSAtom*> >, js::TempAllocPolicy>::MapHashPolicy, js::TempAllocPolicy>::destroyTable mfbt/HashTable.h:1647
1 xul.dll void js::XDRIncrementalEncoder::~XDRIncrementalEncoder js/src/vm/Xdr.h:562
2 xul.dll void js::XDRIncrementalEncoder::~XDRIncrementalEncoder js/src/vm/Xdr.h:562
3 xul.dll js::ScriptSource::~ScriptSource js/src/vm/JSScript.h:732
4 xul.dll js::SourceCompressionTask::~SourceCompressionTask js/src/vm/HelperThreads.h:838
5 xul.dll void js::SourceCompressionTask::~SourceCompressionTask js/src/vm/HelperThreads.h:838
6 xul.dll js::AttachFinishedCompressions js/src/vm/HelperThreads.cpp:2459
7 xul.dll static void SweepCompressionTasks js/src/gc/GC.cpp:5110
8 xul.dll void js::GCParallelTask::runFromHelperThread js/src/vm/HelperThreads.cpp:1806
9 xul.dll void js::HelperThread::handleGCParallelWorkload js/src/vm/HelperThreads.cpp:1827

See Also: → 1586433

This looks like Bug 1585874. It should be fixed by that patch.

Iain, could we quickly validate this is fixed by Bug 1585874 and close this as a duplicate if so.

Flags: needinfo?(iireland)

This is a duplicate of Bug 1585874.

Status: NEW → RESOLVED
Closed: 2 years ago
Flags: needinfo?(iireland)
Resolution: --- → DUPLICATE
Duplicate of bug: 1585874
You need to log in before you can comment on or make changes to this bug.