Closed Bug 1586539 Opened 1 year ago Closed 6 months ago

Attach to processes for OOP iframes when debugging a browsing context

Categories

(DevTools :: Debugger, enhancement, P2)

enhancement

Tracking

(Fission Milestone:M6)

RESOLVED DUPLICATE of bug 1626655
Fission Milestone M6

People

(Reporter: bhackett1024, Assigned: bhackett1024)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

Attached image screenshot.png

With the changes in bug 1580168, when debugging a tab the debugger client can match up the pids returned by listProcesses() with the pids associated with the remote frames of the target tab. This allows the debugger to attach to those processes associated with its target, even when not using the OBT. With the changes in bug 1586359 and bug 1586468, the content processes listed will update as iframes are added or removed.

Priority: -- → P3
Depends on: 1574350

Tentatively moving all bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to the "?" triage milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → ?

Blocks enabling Fission in Nightly (M6).

Fission Milestone: ? → M6
Attachment #9099042 - Attachment is obsolete: true
Priority: P3 → P2
Whiteboard: dt-fission-m2-mvp

bug 1626655 is going to accomplish this. By migrating the Debugger to the TargetList, the Debugger will be debugging all targets kinds the same way, including OOP frames.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1626655
Whiteboard: dt-fission-m2-mvp
You need to log in before you can comment on or make changes to this bug.