Text after <iframe/> is ignored

VERIFIED INVALID

Status

()

Core
Layout
VERIFIED INVALID
16 years ago
11 years ago

People

(Reporter: Jos.vandenOever, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
When using a empty iframe in XHTML Transitional:
<iframe src="http://www.mozilla.org/"/>, the text after the element is ignored,
even though it shouldn't be.
(Reporter)

Comment 1

16 years ago
Created attachment 92221 [details]
same page as mentioned in the url

Comment 2

16 years ago
You get HTML parsing with a text/html content-type. If you change it to 
application/xhtml+xml (and add the namespace declaration) it works fine.

See: http://www.w3.org/TR/2002/NOTE-xhtml-media-types-20020430/
(Reporter)

Comment 3

16 years ago
Created attachment 92227 [details]
same file, but now application/xhtml+xml
umm, you forgot the namespace declaration.
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
in place of
<html>
It looks great with Content-Type text/xml or application/xhtml+xml

-> INVALID; not a bug

Reporter: Please reopen if you disagree.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
verified invalid.  The XHTML 1.0 Recommendation, Appendix C, says:

  Given an empty instance of an element whose content model is not EMPTY (for
  example, an empty title or paragraph) do not use the minimized form (e.g. use
  <p> </p> and not <p />).

The same recommendation says:

  However, XHTML Documents which follow the guidelines set forth in Appendix C,
  "HTML Compatibility Guidelines" may be labeled with the Internet Media Type 
  "text/html", as they are compatible with most HTML browsers. This document
  makes no recommendation about MIME labeling of other XHTML documents.

The document in question does not follow Appendix C, so it may not be labeled as
text/html (since it is not in fact valid HTML).
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
*** Bug 212670 has been marked as a duplicate of this bug. ***

Comment 7

14 years ago
*** Bug 246584 has been marked as a duplicate of this bug. ***
*** Bug 310959 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
(In reply to comment #8)      
> *** Bug 310959 has been marked as a duplicate of this bug. ***      
If this is a duplicate of any bug, it is a duplicate of bug 282409.     
Additionally, the outer frame validates ok against the w3 validator, as do the     
first two emnedded frames. If the markup is valid, I expect it to be rendered     
correctly, and not be fobbed off with some spurious and obviously incorrect   
excuse. The fact is simple: Mozilla fails to correctly render this markup and   
has been incapable of doing so since July 2002 according to this bug.   

Comment 10

12 years ago
*** Bug 317800 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
*** Bug 318557 has been marked as a duplicate of this bug. ***
*** Bug 351655 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.