Crash when removing cc: or to: recipient lines from compose

VERIFIED DUPLICATE of bug 158202

Status

MailNews Core
Composition
--
critical
VERIFIED DUPLICATE of bug 158202
16 years ago
9 years ago

People

(Reporter: Eric Hedström, Assigned: varada)

Tracking

({crash})

Trunk
x86
Windows 2000
crash

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Windows 2000 2002071908-trunk
Steps:
Reply-all to a message that had multiple recipients.
Select a cc: address and delete it by hitting Backspace.
Hit Backspace again to remove the empty line.

expected: the empty recipient line goes away
actual: about one time out of 4, Mozilla crashes

See talkback IDs TB8560586K and TB8559994H.

I doubt it's relevant, but I am using IMAP servers and LDAP for addressing.
Happens with both MS Exchange 5.5 and UW IMAP.
--> over to varada, might be a dup!
Assignee: ducarroz → varada

Comment 2

16 years ago
Both talkback reports look to be similar...
Talkback incident: 8559994 
nsXULElement::GetOwnerDocument
[c:/builds/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp, line 931]
XPTC_InvokeByIndex
[c:/builds/seamonkey/mozilla/xpcom/reflect/xptcall/src/md/win32/xptcinvoke.cpp,
line 106]
XPCWrappedNative::CallMethod
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 1996]
XPC_WN_GetterSetter
[c:/builds/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1299]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 790]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
js_GetProperty [c:/builds/seamonkey/mozilla/js/src/jsobj.c, line 2526]
js_Interpret [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 2576]
js_Invoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 806]
js_InternalInvoke [c:/builds/seamonkey/mozilla/js/src/jsinterp.c, line 881]
JS_CallFunctionValue [c:/builds/seamonkey/mozilla/js/src/jsapi.c, line 3430]
nsJSContext::CallEventHandler
[c:/builds/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1045]
GlobalWindowImpl::RunTimeout
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 4575]
GlobalWindowImpl::TimerCallback
[c:/builds/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line 4922]
nsTimerImpl::Fire [c:/builds/seamonkey/mozilla/xpcom/threads/nsTimerImpl.cpp,
line 340]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 597]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 530]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1078]
nsAppShellService::Run
[c:/builds/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp, line 452]
main1 [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1527]
main [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1874]
WinMain [c:/builds/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1892]
WinMainCRTStartup()
KERNEL32.dll + 0xd326 (0x77e8d326) 

Updated

16 years ago
Severity: normal → critical
Keywords: crash

Comment 3

16 years ago
looks the same as 158202

*** This bug has been marked as a duplicate of 158202 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

14 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.