Closed Bug 1586884 Opened 10 months ago Closed 10 months ago

The overflow menu arrow is overlaping the popup in customize mode

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + verified

People

(Reporter: itiel_yn8, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image Screenshot

This is a regression from bug 1582530 (more spefically, the Fix remaining cases that were relying on blockification patch)

See attached.

[Tracking Requested - why for this release]:

(In reply to Itiel from comment #0)

more spefically, the Fix remaining cases that were relying on blockification patch

This doesn't really make sense to me; it doesn't look like that change touched the arrow in any way so I don't see how it'd affect this...

Anyway, :ntim/:dao/:dholbert, thoughts?

Component: Layout → Toolbars and Customization
Flags: needinfo?(ntim.bugs)
Flags: needinfo?(dholbert)
Flags: needinfo?(dao+bmo)
Priority: -- → P1
Product: Core → Firefox

This was likely a regression from the other patch in that push, which flipped a pref to make it so some XUL elements that were implicitly getting forced to display:block will no longer have their display changed like that (so now they remain display:-moz-box).

If I flip layout.css.xul-box-display-values.survive-blockification.enabled = false and then enter customize mode, then I get EXPECTED RESULTS. (No need to restart Firefox even).

So this was definitely a regression from that pref-flip, and we likely just need to add an explicit display:block for some element here.

Flags: needinfo?(dholbert)

looks like the rule for...

#customization-panelWrapper > .panel-arrowbox {

...needs display:block, because that element's parent #customization-panelWrapper is display:flex, and flex containers blockify their children. (And until now, that has meant that it forced its child to display:block, but now it leaves it at display:-moz-box instead, which has a subtly different layout in this case, hence this bug report.)

Flags: needinfo?(ntim.bugs)
Flags: needinfo?(dao+bmo)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/7e80d0687f27
Fix overflow menu arrow appearance in customize mode. r=Gijs
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Assignee: nobody → ntim.bugs
Flags: qe-verify+

Hello! Reproduced the issue with Firefox 71.0a1 (20191007215350) on Windows 10x64.
The issue is verified fixed with Firefox 71.0b9 (20191111170815) on Windows 10x64, Ubuntu 18.04 and macOS 10.12.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.