Closed Bug 1586997 Opened 2 years ago Closed 2 years ago

New Folder / New Bookmark: no focus on text field

Categories

(Firefox :: Bookmarks & History, defect, P2)

71 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed

People

(Reporter: wendelvolm, Assigned: ntim)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

To reproduce:
Right click -> New Folder / New Bookmark

Mac-OS 10.14.6, FF nightly 71.0a1, build 20191007215350, occurs in clean profile

Actual results:

Dialog pops up, no focus anywhere

Expected results:

Dialog pops up, I can start typing immediately (focus on first text input field)

When editing a bookmark it works as it should

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Bookmarks & History

It looks like a regression, maybe related to the XBL removal work.
We need a regression-range.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: qe-verify?
Priority: -- → P2

Tim, any idea what may have changed here?

Flags: needinfo?(ntim.bugs)
Regressed by: 1562664
Assignee: nobody → ntim.bugs
Flags: needinfo?(ntim.bugs)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/825cabc40708
Fix focusing the first input of edit bookmark dialogs. r=mak
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71

Hey Tim. When you have time, mind confirming the QE? status?
Thanks in advance!

Flags: needinfo?(ntim.bugs)
Flags: qe-verify?
Flags: qe-verify-
Flags: needinfo?(ntim.bugs)
You need to log in before you can comment on or make changes to this bug.