Closed Bug 1587427 Opened 2 years ago Closed 1 year ago

Fix usage of nsIDocShellTreeItem in nsFocusManager::IsSameOrAncestor

Categories

(Core :: DOM: Navigation, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1646542

People

(Reporter: djvj, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [rm-docshell-tree-item:hard])

https://searchfox.org/mozilla-central/rev/7cc0f0e89cb40e43bf5c96906f13d44705401042/dom/base/nsFocusManager.cpp#1357

This entire method should be changed to accept BrowsingContext* arguments instead of nsIDocShellTreeItem* methods, and its users changed accordingly to pass the appropriate arguments.

Whiteboard: [rm-docshell-tree-item:hard]
Fission Milestone: --- → M5
Priority: -- → P2
Fission Milestone: M5 → Future

Kannan says replacing nsIDocShellTreeItem calls should block enabling Fission in Nightly (M6).

Fission Milestone: Future → M6
Summary: Fix usage of nsIDocShellTreeItem in nsContentUtils::IsSameOrAncestor → Fix usage of nsIDocShellTreeItem in nsFocusManager::IsSameOrAncestor

Auditing whether this use of nsIDocShellTreeItem breaks when Fission is enabled blocks Fission Nightly.

Fission Milestone: M6 → M6b
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1646542

Clearing Fission Milestone for bugs resolved as duplicates. We don't need to track duplicates.

Fission Milestone: M6b → ---
You need to log in before you can comment on or make changes to this bug.