Closed Bug 1587468 Opened 5 months ago Closed 2 months ago

Update syn and quote to 1.0

Categories

(Firefox Build System :: General, task)

task
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: emilio, Assigned: emilio)

References

(Blocks 1 open bug)

Details

Attachments

(12 files)

47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review
47 bytes, text/x-phabricator-request
Details | Review

https://hg.mozilla.org/integration/autoland/rev/713dee70307d pulls the new syn and quote versions. We should update all the crates to not duplicate the dependency.

PRs to track:

And then there's the workspace-hack which uses syn and quote with very concrete dependencies. I'll try to figure out what the right thing to do is there.

This is only used by webdriver.

Keywords: leave-open
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4a1a65319a43
Update cssparser to v0.25.9. r=boris
https://hg.mozilla.org/integration/autoland/rev/6e641b4a78b5
Update cssparser-macros to 0.3.6. r=boris
https://hg.mozilla.org/integration/autoland/rev/d773bdf9f8e0
Update cstr-macros to v0.1.6. r=boris
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/241a2e6159b0
Update num_derive to 0.3. r=boris
https://hg.mozilla.org/integration/autoland/rev/16c3040fb388
Update syn / quote / synstructure in peek-poke-derive. r=jrmuizel
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/405b9a7fec75
Add syn/quote/etc to the list of allowed duplicated WR dependencies for now. r=bustage
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/091a5a4ec150
Update headers_derive to v0.1.1. r=ato

This removes an old version of synstructure.

We are no longer using a pinned version of serde, so update to avoid the
dependency on older syn / quote / etc.

Attachment #9109322 - Attachment description: Bug 1587468 - Update failure_derive and malloc_size_of_derive. r=heycam → Bug 1587468 - Update failure, failure_derive and malloc_size_of_derive. r=heycam
Attachment #9109322 - Attachment description: Bug 1587468 - Update failure, failure_derive and malloc_size_of_derive. r=heycam → Bug 1587468 - Update failure_derive and malloc_size_of_derive. r=heycam
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b168e040a286
Update failure_derive and malloc_size_of_derive. r=heycam
Attachment #9109336 - Attachment description: Bug 1587468 - Update serde and related crates. r=jrmuizel → Bug 1587468 - Update serde and related crates. r=nical
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/285df50f96b2
Update serde and related crates. r=nical

This has the side effect of adding another version of uuid, which we'll
upgrade for other dependencies subsequently.

This leaves one out-of-tree of uuid 0.7, handled by https://github.com/mozilla/rkv/pull/184
(but we have two copies of that, we'd need to have it landed on both
branches and pulled).

With the two patches I attached, we're down to 3 dependencies on syn < 1.0:

I'm tempted to add a check in mach vendor rust that errors out if we add another version of syn...

Depends on: 1601070
Pushed by emilio@crisal.io:
https://hg.mozilla.org/integration/autoland/rev/ebb4441eb500
follow-up: Update webrender's lockfile in a CLOSED TREE.
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/eef1d8be4e7b
Update object to 0.16.0 and goblin to 0.1.2. r=emilio
https://hg.mozilla.org/integration/autoland/rev/c0280f40a197
Update uuid to 0.8.1. r=webdriver-reviewers,whimboo,emilio

(In reply to Pulsebot from comment #29)

https://hg.mozilla.org/integration/autoland/rev/823a7bf8c482
Update lucet-runtime.

This should've landed with r=froydnj, but apparently lando didn't peek the change in-flight...

Bug 1604120 gets rid of the last bit here.

Status: NEW → RESOLVED
Closed: 2 months ago
Depends on: 1604120
Resolution: --- → FIXED
Duplicate of this bug: 1604129
Blocks: 1563925
You need to log in before you can comment on or make changes to this bug.