Closed Bug 1587788 Opened 3 years ago Closed 3 years ago

[Wayland/GL compositor] Visual glitches when selecting text by mouse

Categories

(Core :: Graphics, defect, P3)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: stransky, Assigned: stransky)

References

(Blocks 2 open bugs, )

Details

A page is flickering when text is selected by mouse on Wayland/GL compositor. It does not affect WebRender.

  1. Go to ct24.cz, open any article
  2. Repeatedly select some text and images
  3. See the flickering
Priority: -- → P3

I'll look at it.

Assignee: nobody → stransky

Unable to reproduce with dma buf backend.

Also does not reproduce when switched SHM EGL backend from ContentClientSingleBuffered to ContentClientDoubleBuffered, but that change leads to significant performance drop.

This bug happens only when a frame is composited from more than one texture source - so it happens on particular page location only.

Seems to be caused by upload to texture and then rendering from it shortly after the upload...the texture it not complete. I see no flickering then the textures are not updated and compositor just re-use existing texture content.

Hm, tested with desktop GL (Bug 1474281) but result is the same.

Tracked down to EffectTypes::COMPONENT_ALPHA but still not sure why.

It's caused by incomplete texture upload - reported as MESA bug https://gitlab.freedesktop.org/mesa/mesa/issues/1992

Only workaround here right now is to use dma-buf backend - which needs Bug 1589924 fixed at least.

Closing as Wontfix - better to concentrate to webrender.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.