Hebrew text not wrapped in <textarea>

VERIFIED DUPLICATE of bug 119915

Status

()

Core
Layout: Text
VERIFIED DUPLICATE of bug 119915
16 years ago
10 years ago

People

(Reporter: jeremy.m, Assigned: mkaply)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

16 years ago
Mozilla build 2002072104

The Hebrew text in the textarea in this page isn't wrapped - appears as one long
line.
IE displays the page correct.
(Reporter)

Comment 1

16 years ago
Created attachment 92369 [details]
Mozilla's incorrect rendering.
(Reporter)

Comment 2

16 years ago
Created attachment 92370 [details]
Correct rendering by explorer.
Confirming, but I suspect it's a dupe. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 92423 [details]
Testcase

This testcase shows that this is not a Bidi bug. Adding the cols attribute (as
the HTML spec requires) solves the problem.
kin - is this a dupe of one of your bugs? Or should we move to evangelism since
the HTML is invalid?

Comment 6

16 years ago
I think the spec requires that both cols and rows be present, but I already have
a bug on making textareas wrap with no cols attribute defined for backwards
compatibility, so I'll just dup it to that.

*** This bug has been marked as a duplicate of 119915 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 7

16 years ago
vrfy dupe
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: Layout: BiDi Hebrew & Arabic → Layout: Text
QA Contact: zach → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.