Closed Bug 1588212 Opened 2 years ago Closed 1 year ago

[Android] "contain:size" select elements render with a skinnier intrinsic width than an empty select element

Categories

(Core :: Layout, defect, P3)

Unspecified
Android
defect

Tracking

()

RESOLVED DUPLICATE of bug 1619428

People

(Reporter: dholbert, Unassigned)

References

Details

Attachments

(1 file)

Attached file reftest log snippet

This is a followup to bug 1562057. On Android, we apparently still render intrinsically-sized <select> elements as being too skinny if they have contain:size. (They're supposed to be sized as if they were empty, but in fact we size them a little smaller.)

Failure log:
https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=270910342&repo=autoland&lineNumber=7395

Snippet of log (for reftest-analyzer) attached.

This bug is also tracking Android-only expected-failures in the similarly-named "contain-size-select-001.html" and -002.html (no "elem" in these tests' names)

Log from autoland with those tests' failures (when they were briefly annotated as expected-pass):
https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=a8ea98346a87402b1c3ad4c892694d0de163a0b3&selectedJob=270910351

Bug 1619428 drive-by fixes this.

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1619428
You need to log in before you can comment on or make changes to this bug.