Closed Bug 1588325 Opened 2 years ago Closed 1 year ago

Tabs flash when scrolling through homepage URLs

Categories

(Core :: Graphics: WebRender, defect, P3)

71 Branch
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: ayden, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_11_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/11.1.2 Safari/605.1.15

Steps to reproduce:

I have about 60-70 urls saved in my homepage url string.
in Nightly (Main doesnt appear to do this) I open up homepage and place cursor in url path and scroll right (or hold down to do a select and scroll right as thats faster to scroll across).
even stepping through each character can manually produces the background change. it seems to be about 26-30 chars the tab colour is fine, and then goes white for 4 chars.
The flashing has a repetitive rhythm to it, so it isnt just a single url for example causing the background tab colour to change to white etc.
Even clicking into the homepage url can make tabs go white. I tried screenshotting and the white tab eventually turned black so maybe its just GPU needing to catch up on the render or something.

Actual results:

The tabs at the top background colour transitions between black and white, causing a flashing effect.. Screenshot of white tab attached.

when stepping through it looks like it is about every 26th or so character, then white for about 4 characters but have had it remain white for say 7-9 characters..
It did feel like sometimes it was triggering like 4 chars before an every second | or http: etc and sometimes 4 chars before a random /, almost like it was reading ahead of what could be visually seen in the homepage url box.

Expected results:

tab colour/fonts don't change colours.

Component: Untriaged → Graphics: Text
Product: Firefox → Core

So you have a very long string in your url bar and you are scrolling it when the problem shows up? It sounds like you are using dark mode or a dark theme? Can you upload the contents of about:support as an attachment?

Flags: needinfo?(ayden)
Attached file about support.docx

Hi, updated a .docx containing the about:support as requested.

my homepage url contains @70 odd urls, some are long, some short, the length doesnt affect what flashes and what does not flash.

Flags: needinfo?(ayden)

let me know if you need anything else from me.
Thanks.

Thanks for that. I'm trying to understand what the steps to reproduce this are for you. If you were to describe to someone else how to perform the same actions so they could see the issue on their local computer what would you tell them? Would it be "have a very long url in your url bar and either scroll right using the mouse or hold the right arrow to scroll right"? Would you be able to provide a video of what's happening maybe?

Could you try changing the pref gfx.webrender.all back to false, restart your browser and confirm in about:support that under compositing is says opengl and not webrender, and then try to reproduce?

Last question for now, is this something new that you noticed changed? Or has it always been like that?

Attached video UrlScrolling.mov

Movie of the tab flashing issue when scrolling through homepage URLs. It also happens when scrolling backwards as well though not shown in movie.
Second half is regular FF where it doesn't flash when scrolling

Changed to opengl, confirmed it was set, re-tested and issue has gone away.

I haven't been paying attention so I do not know when the issue originally started sorry.

Thanks for the info.

I would recommend to run without webrender if this bug bothers you. We haven't enabled webrender on mac yet and when we do I would guess that we would probably blacklist cards as old as the one from your about support (geforce 9400m). It's possible that the problem is a driver bug and it's very unlikely Apple would provide an update for that.

Component: Graphics: Text → Graphics: WebRender
Priority: -- → P3

I noticed that my gif issue has gone too, assume from changing to opengl.

previously on ok.ru website quite often when getting to a gif, it wouldn't start plating or only play a small part of it like 1 second and then stop. I would then have to scroll up and back down the screen to try to restart it again often without success.

I don't have these issues on ok.ru since changing to opengl.

(In reply to ayden from comment #8)

I noticed that my gif issue has gone too, assume from changing to opengl.

previously on ok.ru website quite often when getting to a gif, it wouldn't start plating or only play a small part of it like 1 second and then stop. I would then have to scroll up and back down the screen to try to restart it again often without success.

I don't have these issues on ok.ru since changing to opengl.

Hmm, that sounds less like a driver bug and more like a webrender bug.

See Also: → 1637533

It seems like support for older mac OS version will change as per bug 1637533. I can't repro this on 10.13 although I don't have quite as long a URL but I suspect we might not ship WR for 10.11.

Ayden, can you still reproduce this problem?

Flags: needinfo?(ayden)

Hi,
The problem appears not to be there anymore.
I tested on 79.0a1 (2020-06-15) (64-bit)
OS El Capitan version 10.11.6 (15G22010)

Thanks,
Ayden

Flags: needinfo?(ayden)

That was under original setting as well as webrender. Composite says webrender. So appears to be fine now.

But it is odd my nightly is a month old and latest version aparently. im not worried about that, more a fyi to you guys in case that is a problem.

ayden, what happens when you check for updates in your nightly? Also what's the build id (it's listed in about:support)

Flags: needinfo?(ayden)

Hi Jeff,

It says from 'About Nightly' after checking.

79.0a1 (2020-06-15) (64-bit)
Nightly is up to date

About support:
build id: 20200615092624

Flags: needinfo?(ayden)

Weird. It may be worth filing a bug about that in the updater component.

Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.