Closed Bug 1588358 Opened Last month Closed 28 days ago

Clean up SeaMonkey migration code

Categories

(SeaMonkey :: Startup & Profiles, enhancement)

enhancement
Not set

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53 affected, seamonkey2.57esr fixed, seamonkey2.63 wontfix)

RESOLVED FIXED
seamonkey2.68
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 --- affected
seamonkey2.57esr --- fixed
seamonkey2.63 --- wontfix

People

(Reporter: frg, Assigned: frg)

Details

Attachments

(1 file)

Currently the only migration which works is migration from Thunderbird. But even there it tries to migrate some settings and prefs which should not be taken or are not available/make no sense (history, bookmarks). The migration code is also mot separated and breaks frequently with upstream changes. So try to make it a little more aligned with TB and Fx for future enhancements.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: no visible impact.
Testing completed (on m-c, etc.): 2.53
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: None

This could be cleaned up further but should probably be done in a follow-up bug. The sturcuture matches the one form TB afterwards but might be a little overkill for the few files. Unsure.

Attachment #9100734 - Flags: review?(iann_bugzilla)
Attachment #9100734 - Flags: approval-comm-release?
Attachment #9100734 - Flags: approval-comm-esr60?
Comment on attachment 9100734 [details] [diff] [review]
1588358-suitemigration.patch

[Triage Comment]
r/a=me I think this is probably the best starting point but I presume there will be follow-up bugs
Attachment #9100734 - Flags: review?(iann_bugzilla)
Attachment #9100734 - Flags: review+
Attachment #9100734 - Flags: approval-comm-release?
Attachment #9100734 - Flags: approval-comm-release+
Attachment #9100734 - Flags: approval-comm-esr60?
Attachment #9100734 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/2abc5e2495fc
Untangle suite profile and migration source and clean it up. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 28 days ago
Resolution: --- → FIXED

Patches for esr60 and comm-central needed some rebasing.

https://hg.mozilla.org/releases/comm-esr60/rev/ad9f64a2ef8d1788dd77c32053c3ab940d08e049

Target Milestone: --- → seamonkey2.68
You need to log in before you can comment on or make changes to this bug.