Closed Bug 1588359 Opened 4 months ago Closed 4 months ago

Crash in [@ mozilla::dom::ServiceWorkerShutdownBlocker::WaitOnPromise]

Categories

(Core :: DOM: Service Workers, defect, P2, critical)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1591101

People

(Reporter: jseward, Unassigned)

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-413cc0f1-179a-4530-bdff-a0ab90191011.

This crash appears in two different instances of the OSX nightly 20191010092637.
Possibly related to bug 1588356 or bug 1588357?

Top 10 frames of crashing thread:

0 XUL mozilla::dom::ServiceWorkerShutdownBlocker::WaitOnPromise dom/serviceworkers/ServiceWorkerShutdownBlocker.cpp:95
1 XUL mozilla::dom::ServiceWorkerPrivateImpl::Shutdown dom/serviceworkers/ServiceWorkerPrivateImpl.cpp:867
2 XUL mozilla::dom::ServiceWorkerPrivate::ReleaseToken dom/serviceworkers/ServiceWorkerPrivate.cpp:2102
3 XUL mozilla::dom::FetchEventOpChild::~FetchEventOpChild dom/serviceworkers/FetchEventOpChild.cpp:201
4 XUL mozilla::dom::FetchEventOpChild::~FetchEventOpChild dom/serviceworkers/FetchEventOpChild.cpp:197
5 XUL mozilla::dom::PRemoteWorkerControllerChild::ClearSubtree ipc/glue/ProtocolUtils.cpp:253
6 XUL mozilla::ipc::PBackgroundChild::ClearSubtree ipc/ipdl/PBackgroundChild.cpp:6722
7 XUL mozilla::ipc::PBackgroundChild::OnChannelClose ipc/ipdl/PBackgroundChild.cpp:6442
8 XUL  ipc/glue/BackgroundImpl.cpp:1706
9 XUL  ipc/glue/BackgroundImpl.cpp:1354

Flags: needinfo?(bugmail)
Priority: -- → P2

Pretty sure this is bug 1591101. I'm hoping the robot transfers the signature?

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(bugmail)
Resolution: --- → DUPLICATE
Duplicate of bug: 1591101
You need to log in before you can comment on or make changes to this bug.