Closed Bug 1588402 Opened 3 years ago Closed 10 months ago

Multiple CONTENT_FRAME_TIME regressions on Intel cards

Categories

(Core :: Graphics: WebRender, defect, P2)

defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: mattwoodrow, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

https://metrics.mozilla.com/webrender/dashboard_intel.html#content_frame_time

It looks like there have been a few regressions for our CONTENT_FRAME_TIME numbers, causing us from being similar (or slightly better) than non-WR to now being significantly worse.

These appear to be specific to Intel, and there doesn't seem to be much movement on the NVIDIA/AMD dashboards.

These are even more visible on the Tab Switch 'all builds' graph. Look like roughly 04/29 and 08/15.

Tim, are you able to pull the precise numbers for these graphs, so we can know exactly which build regressed here?

Flags: needinfo?(tdsmith)
Attached image August regression

The August regression looks like it landed between Aug 1 and Aug 2.

Attached image Tab switch regression

The earlier regression in tab switch time looks like a regression in the non-Webrender case starting at the beginning of June.

Flags: needinfo?(tdsmith)

I looked at this some more. There's nothing that jumped out to me as an obvious cause in that time window. Looking at some of the charts it appears like there may have been some changes in the reporting/enrollment that could have caused the change instead of a code change.

More investigation to come.

Blocks: wr-71
No longer blocks: wr-70
Priority: -- → P2

We figured out what was going on with our enrollment and it seems unrelated to this. Further investigation required.

Blocks: wr-72
No longer blocks: wr-71
Blocks: wr-74
No longer blocks: wr-72

We are going to look at this again once Direct Composition lands

We looked at this and it worse Direct Composition because DirectComposition spends more time in Commit() than we did in Present(). However that doesn't actually mean that we're worse. We should try to measuring something better.

Blocks: wr-75
No longer blocks: wr-74
Blocks: wr-perf
No longer blocks: wr-75
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.