Closed Bug 1588649 Opened 2 years ago Closed 2 years ago

release update verify secondary failing for 70.0

Categories

(Release Engineering :: General, defect)

defect
Not set
normal

Tracking

(firefox-esr60 unaffected, firefox-esr68 unaffected, firefox67 unaffected, firefox68 unaffected, firefox69 unaffected, firefox70 fixed, firefox71 fixed)

RESOLVED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox67 --- unaffected
firefox68 --- unaffected
firefox69 --- unaffected
firefox70 --- fixed
firefox71 --- fixed

People

(Reporter: jlund, Assigned: nthomas)

References

Details

Attachments

(1 file)

No description provided.

eg https://taskcluster-artifacts.net/Hut4xx9YQZi4Xz9gIemI8A/0/public/logs/live_backing.log

calling QuitProgressUI
Comparing source/firefox with target/firefox...
Difference found in update-settings.ini
Transforms removed all differences
Difference found in defaults/pref/channel-prefs.js
defaults/pref/channel-prefs.js still differs after transforms, residual diff:
---
+++
@@ -1,9 +1,5 @@
 /* This Source Code Form is subject to the terms of the Mozilla Public
  * License, v. 2.0. If a copy of the MPL was not distributed with this
  * file, You can obtain one at http://mozilla.org/MPL/2.0/. */
-//
-// This pref is in its own file for complex reasons. See the comment in
-// browser/app/Makefile.in, bug 756325, and bug 1431342 for details. Do not add
-// other prefs to this file.

 pref("app.update.channel", "beta");
TEST-UNEXPECTED-FAIL: differences found after update
TEST-UNEXPECTED-FAIL: [70.0 cak complete] check_updates returned failure for Linux_x86_64-gcc3 downloads/firefox-70.0b14.tar.bz2 vs. downloads/firefox-70.0.tar.bz2: 1

The fix in bug 1577634 might be backfiring. It was designed to handle updating to a beta which has the comments in channel-prefs.js, by removing them from the target side. Now that we are doing 70.0b14 -> 70.0 RC build the comments are present on both sides so there is no diff but we appear to create one. But I don't understand why we didn't hit this for a 70.0b13 -> 70.0b14 update.

See Also: → 1577634

(In reply to Nick Thomas [:nthomas] (UTC+12) from comment #2)

The fix in bug 1577634 might be backfiring. It was designed to handle updating to a beta which has the comments in channel-prefs.js, by removing them from the target side. Now that we are doing 70.0b14 -> 70.0 RC build the comments are present on both sides so there is no diff but we appear to create one. But I don't understand why we didn't hit this for a 70.0b13 -> 70.0b14 update.

Turns out the last case never needs to try to apply any transforms because channel-prefs.js is identical. It's only when the default channel changes to release in the rc that we start applying transforms, and the earlier fix breaks things. Since we stop trying to apply transforms once the files are identical we can just shuffle the transform order around.

Assignee: nobody → nthomas

The fix in Bug 1577634 only worked for the beta channel as it didn't consider the RC case.

There's several situations:

  • beta without comments --> beta with comments: handled by bug 1577634, but with fallout
  • beta with comments --> beta with comments: channel-prefs.js is identical so we never need to apply any transforms
  • beta with comments --> rc with comments: the channel changes in channel-prefs.js (by design) so we apply transforms
  • rc with comments --> beta with comments: the channel changes in channel-prefs.js (by design) so we apply transforms

By moving the channel fixing transforms forward the file will become identical before we need to try the comment transform. The code breaks early in this case.

The release/esr case is simpler:

  • release without comments --> release with comments: handled by comment transform, channel transforms only used for beta tests
  • release with comments --> release with comments: channel-prefs.js already identical, no transforms applied
Pushed by nthomas@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/36752259f6f8
release update verify secondary failing for 70.0, r=jlund

On release for 70.0 build2/rc2:
https://hg.mozilla.org/releases/mozilla-release/rev/e972ac25e3eea00dbdaed8a0ca5502769c65bbb1

Will be uplifted to beta by sheriffs or during 2nd merge day.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1588655
You need to log in before you can comment on or make changes to this bug.