Closed Bug 1588726 Opened 4 months ago Closed 3 months ago

Closing crazygames page throws NS_ERROR_UNEXPECTED errors in browser console

Categories

(Core :: Networking, defect, P2)

defect

Tracking

()

VERIFIED FIXED
mozilla72
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- wontfix
firefox67 --- wontfix
firefox68 --- wontfix
firefox69 --- wontfix
firefox70 --- wontfix
firefox71 --- wontfix
firefox72 --- verified

People

(Reporter: cfogel, Assigned: kershaw)

Details

(Keywords: regression, Whiteboard: [necko-triaged])

Attachments

(1 file)

Affected versions

  • 70.0(snap), 69.0.3, 71.0a1 (2019-10-14), 68.1esr

Affected platforms

  • macOS 10.13, Ubuntu 16.04,

Steps to reproduce

  1. Launch Firefox;
  2. Access https://www.crazygames.com/
  3. Open the Browser Console (CTRL+SHIFT+J)
  4. Close the browser.

Expected result

  • no error messages displayed in the browser console;

Actual result

  • Errors listed in browser console:
    Webconsole context has changed
    TypeError: state is undefined
    BrowserElementParent.jsm:314:25
    NS_ERROR_UNEXPECTED:
    TypeError: state is undefined
    BrowserElementParent.jsm:314:25
    NS_ERROR_UNEXPECTED:
    NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIProgressEventSink.onStatus] 2 network-response-listener.js:101
    NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIProgressEventSink.onProgress] network-response-listener.js:101
    NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIProgressEventSink.onStatus] network-response-listener.js:101
    NS_ERROR_UNEXPECTED: Component returned failure code: 0x8000ffff (NS_ERROR_UNEXPECTED) [nsIProgressEventSink.onStatus]

Regression range

  • First bad revision: 445255800255bb13ed096b5b7da36aa835e41dd8 (2018-04-02);
  • Last good revision: ef717c03ff54d10b2e30df7e63fc11172c69db44 (2018-04-01);
  • Pushlog: URL
  • Potential regressor:

Additional notes

  • 60.9.0esr not affected;

Wontfix for 71 given that we are in soft code freeze week before beta and the regression is minor and dates back to 61.

We return NS_ERROR_UNEXPECTED at here since IPC channel is closed.
I think we can return NS_OK to avoid annoying error messages.

Assignee: nobody → kershaw
Priority: -- → P2
Whiteboard: [necko-triaged]
Pushed by kjang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/98e4faebf087
Return NS_OK if IPC channel is closed r=valentin
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Verified with 72.0a1 (2019-10-22) on macOS 10.13, Ubuntu 16.04, Windows 10.

Updating status based on above flags.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.