Closed Bug 1588778 Opened 6 months ago Closed 6 months ago

Enable dom/tests/mochitest/bugs/test_bug369306.html for fission debug build

Categories

(Core :: DOM: Core & HTML, task, P2)

task

Tracking

()

RESOLVED FIXED
mozilla72
Fission Milestone M4
Tracking Status
firefox72 --- fixed

People

(Reporter: alchen, Assigned: alchen)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

No description provided.
Assignee: nobody → alchen
Status: NEW → ASSIGNED
Priority: -- → P2

I found some failures on try server when enabling the test for fission.

08:45:35 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/bugs/test_bug369306.html | Test timed out.

08:45:36 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/bugs/test_bug369306.html | [SimpleTest.finish()] waitForFocus() was called a different number of times from the number of callbacks run. Maybe the test terminated prematurely -- be sure to use SimpleTest.waitForExplicitFinish(). - got 1, expected +0

08:45:41 ERROR - /tests/dom/tests/mochitest/bugs/test_bug369306.html logged result after SimpleTest.finish(): [SimpleTest.finish()] waitForFocus() was called a different number of times from the number of callbacks run. Maybe the test terminated prematurely -- be sure to use SimpleTest.waitForExplicitFinish().

(In reply to Alphan Chen [:alchen] from comment #1)

I found some failures on try server when enabling the test for fission.

08:45:35 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/bugs/test_bug369306.html | Test timed out.

08:45:36 INFO - TEST-UNEXPECTED-FAIL | dom/tests/mochitest/bugs/test_bug369306.html | [SimpleTest.finish()] waitForFocus() was called a different number of times from the number of callbacks run. Maybe the test terminated prematurely -- be sure to use SimpleTest.waitForExplicitFinish(). - got 1, expected +0

08:45:41 ERROR - /tests/dom/tests/mochitest/bugs/test_bug369306.html logged result after SimpleTest.finish(): [SimpleTest.finish()] waitForFocus() was called a different number of times from the number of callbacks run. Maybe the test terminated prematurely -- be sure to use SimpleTest.waitForExplicitFinish().

After investigation, I found the failures are caused by test_bug346659, not test_bug369306.html itself.

Summary: Enable dom/tests/mochitest/bugs/test_bug369306.html for fission → Enable dom/tests/mochitest/bugs/test_bug369306.html for fission debug build

There is no failure when enabling "test_bug369306.html" on fission debug build.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=0e82d6f7b38a4b649a640a214b443775cde06687

Keywords: checkin-needed

Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32edc29b094c
Enable dom/tests/mochitest/bugs/test_bug369306.html for fission debug build r=mccr8

Keywords: checkin-needed
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Retroactively moving fixed bugs whose summaries mention "Fission" (or other Fission-related keywords) but are not assigned to a Fission Milestone to an appropriate Fission Milestone.

This will generate a lot of bugmail, so you can filter your bugmail for the following UUID and delete them en masse:

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: --- → M4
You need to log in before you can comment on or make changes to this bug.