Closed Bug 1588883 Opened Last month Closed 28 days ago

Fullscreen transition message doesn't appear anymore

Categories

(Firefox :: General, defect, P1)

defect

Tracking

()

RESOLVED FIXED
Firefox 71
Tracking Status
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 + fixed

People

(Reporter: mconley, Assigned: ablayelyfondou)

References

(Blocks 1 open bug, Regression)

Details

Attachments

(1 file)

STR:

  1. Visit any YouTube video
  2. Fullscreen the video

ER:

A message should come down from the top of the screen saying that we've transitioned to fullscreen mode, and that the user needs to press escape to leave it.

AR:

No message.

I expect this is fallout from bug 1505916. Do you have time to look at this, Abdoulaye?

Flags: needinfo?(ablayelyfondou)

[Tracking Requested - why for this release]:

The message that tells users how to leave fullscreen is missing, and I imagine we don't want to ship to users without it.

Priority: -- → P1

It might be related to how NewOrigin message is passed. That is the message triggers that notification.

(In reply to Xidorn Quan [:xidorn] UTC+10 from comment #2)

It might be related to how NewOrigin message is passed. That is the message triggers that notification.

Thanks Xidorn! I was wondering what this message serves despite trying to disable it to see its effect but was not able to notice that the message disappeared.

(In reply to Mike Conley (:mconley) (:⚙️) (Wayyyy behind on needinfos) from comment #0)

STR:

  1. Visit any YouTube video
  2. Fullscreen the video

ER:

A message should come down from the top of the screen saying that we've transitioned to fullscreen mode, and that the user needs to press escape to leave it.

AR:

No message.

I expect this is fallout from bug 1505916. Do you have time to look at this, Abdoulaye?

Thanks Mike. I will have a look at this.

Flags: needinfo?(ablayelyfondou)
Assignee: nobody → ablayelyfondou
Blocks: 1589238
Component: XUL Widgets → General
Product: Toolkit → Firefox
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/60de2918cb73
Restore fullscreen transition message. r=mconley
Status: NEW → RESOLVED
Closed: 28 days ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 71
Duplicate of this bug: 1589671
You need to log in before you can comment on or make changes to this bug.