Closed Bug 1589056 Opened 1 year ago Closed 1 year ago

mozlog needs to support PRECONDITION_FAILED test and subtest status

Categories

(Testing :: Mozbase, enhancement, P3)

enhancement

Tracking

(firefox72 fixed)

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: foolip, Assigned: foolip)

References

Details

Attachments

(4 files, 2 obsolete files)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36

Steps to reproduce:

https://github.com/web-platform-tests/wpt/pull/16689 needs a PRECONDITION_FAILED status for tests and subtests in order to be able to support the new assert_precondition method in testhharness.js.

I have prepared some changes in https://github.com/mozilla/gecko-dev/compare/master...foolip:bug1589056?expand=1, requested try access in 1589061 to see if they work at all.

Priority: -- → P3
Attachment #9101600 - Attachment is obsolete: true
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/4253a2fb8848
[mozlog] introduce PRECONDITION_FAILED status r=jgraham
https://hg.mozilla.org/integration/autoland/rev/6bd10819c814
[mozlog] tests for PRECONDITION_FAILED status r=jgraham

Resubmitting changes backed out due to lint failure:
https://bugzilla.mozilla.org/show_bug.cgi?id=1589056#c6

Lint and tests verified to work locally with:

./mach lint testing/mozbase/mozlog/
./mach python-test testing/mozbase/mozlog/

Attachment #9103548 - Attachment is obsolete: true
Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/165dd3fa6c49
[mozlog] introduce PRECONDITION_FAILED status r=jgraham
https://hg.mozilla.org/integration/autoland/rev/c8663c3c21a3
[mozlog] tests for PRECONDITION_FAILED status r=jgraham

This is needed to release a new mozlog with the PRECONDITION_FAILED
test and subtest status for use in web-platform-tests.

Update all in-tree dependencies on mozlog to >=5.0. These were found
with hg grep 'mozlog.*[0-9]'.

Only testing/web-platform/tests/tools/wptrunner/requirements.txt
remains on 4.2.0, and it will be updated in upstream wpt after mozlog
5.0 has been released.

Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/753beb12fdf6
[mozlog] Update mozlog version number to 5.0 r=jgraham
Status: UNCONFIRMED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Flags: needinfo?(james)

This is needed because the currently released versions use dependencies
like 'mozlog ~= 4.2.0', which won't match the newly released mozlog 5.0.
The dependencies were updated to 'mozlog >= 5.0' recently:
https://hg.mozilla.org/mozilla-central/rev/753beb12fdf6984c0a2ca8786fb9db1317e171b4

Pushed by james@hoppipolla.co.uk:
https://hg.mozilla.org/integration/autoland/rev/6e89821525db
[mozprofile][mozrunner][mozrunner] bump minor versions r=jgraham
See Also: → 1621106
You need to log in before you can comment on or make changes to this bug.