bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

line break needed after quote line ("... wrote:") when quoting original message using Options->Quote Message

RESOLVED WORKSFORME

Status

MailNews Core
Composition
RESOLVED WORKSFORME
16 years ago
10 years ago

People

(Reporter: J Luh, Assigned: Pete Zha)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
When you use Options->Quote Message to quote the original message in a reply,
Mozilla fails to add a line break after the quote line. I have experienced this
with 1.1b on Windows XP and Mac OS X.

To reproduce:
1. Uncheck "Automatically quote the original message when replying" in Mail
Composition prefs.
2. Begin composing a message reply.
3. Choose Options->Quote Message.

What happens:
original message appears like this:

Sender wrote:>message here
>

What should happen:
original message should be appear like this:

Sender wrote:
> message here
>
(Reporter)

Updated

16 years ago
Keywords: mozilla1.1
Confirming with build 2002081209 and mozilla 1.0

The problem only appears if compose window is set to use plain text only. It
works with HTML.
(Reporter)

Updated

16 years ago
Keywords: nsbeta1
(Assignee)

Comment 2

16 years ago
taking
Assignee: ducarroz → pete.zha
(Reporter)

Updated

16 years ago
Keywords: mozilla1.1 → mozilla1.2

Comment 3

16 years ago
Looks to me like dupe of Bug 91576 or Bug 67391
(Reporter)

Comment 4

16 years ago
This is not a duplicate of either of those bugs. Bug 67391 Bug 91576 is asking
for an extra newline (2 newlines) between the quote line and the quoted text.
Bug 67391 is talking about newlines added where they should not be.

Comment 5

16 years ago
I missed the one I really meant, bug 109935.

Comment 6

16 years ago
This may be a place to suggest my preference that the user have the option of
selecting a "bracketed" quote, surrounded by lines of preselected bracket
characters, instead of an indented quote, and be enabled to pre-select the
bracket or indent characters. Bracketing preserves the nested quote structure
while enabling readers to more easily copy and paste quoted material without
having to remove the indent characters, and avoids the wrapping of deeply nested
quoted lines.

Comment 7

16 years ago
*** Bug 176993 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 8

16 years ago
Created attachment 106079 [details] [diff] [review]
use nsIPlainTextEditor if not in html mode
(Assignee)

Comment 9

16 years ago
Comment on attachment 106079 [details] [diff] [review]
use nsIPlainTextEditor if not in html mode

request r=/sr=...
(Assignee)

Comment 10

16 years ago
CC ducarroz and bienvenu for r= and sr=
(Assignee)

Updated

16 years ago
Attachment #106079 - Flags: review?(ducarroz)
(Assignee)

Updated

16 years ago
Attachment #106079 - Flags: superreview?(bienvenu)
Comment on attachment 106079 [details] [diff] [review]
use nsIPlainTextEditor if not in html mode

Thanks for fixing this problem. R=ducarroz
Attachment #106079 - Flags: review?(ducarroz) → review+

Comment 12

16 years ago
Comment on attachment 106079 [details] [diff] [review]
use nsIPlainTextEditor if not in html mode

sr=bienvenu, but it looks like the prevailing braces style is 
if ()
{
}
else
{
}
not if () {
}else {

so please fix that before checking in.
Attachment #106079 - Flags: superreview?(bienvenu) → superreview+
(Assignee)

Comment 13

16 years ago
Created attachment 106755 [details] [diff] [review]
patch which I want to check in with bienvenu's comments

Comment 14

16 years ago
that's fine, you don't need another round of reviews.
(Assignee)

Comment 15

16 years ago
thanks:)
checked in
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 16

16 years ago
Uisng trunk builds 20021121 on winxp, linux and macosx, This is fixed on linux
and winxp but I don't see the fix in Mac OSX.  
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

16 years ago
This is a cross platform bug. I don't see why this doesn't work on Mac OSX...
(Reporter)

Updated

16 years ago
Keywords: mozilla1.2 → mozilla1.3

Comment 18

16 years ago
Trunk build 2003-02-05: Mac 10.1.
Trunk bild 2003-02-05: WinMe
It appears to be working for me using the above builds. Esther, how does this
work on your Mac system?

Comment 19

16 years ago
Ninoschka and I both checked into this and found that it works on the MACO trunk
builds but not the MAC OSX trunk builds.  
Mail Triage: nsbeta1-
Keywords: nsbeta1 → nsbeta1-
Product: MailNews → Core

Comment 21

13 years ago
This is WFM with Mozilla 1.7.7 and current nightlies, both on Mac OS 10.4.
Status: REOPENED → RESOLVED
Last Resolved: 16 years ago13 years ago
Resolution: --- → FIXED

Comment 22

13 years ago
No specific bug / patch referenced as the fix for MacOS 10.

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

13 years ago
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.