Closed Bug 1589251 Opened 3 years ago Closed 3 years ago

On wayland, clicking a link outside of firefox makes it incorrectly say "Firefox is already running, but not responding"

Categories

(Core :: Widget: Gtk, defect)

69 Branch
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1508803

People

(Reporter: vreyesvaldivieso, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:69.0) Gecko/20100101 Firefox/69.0

Steps to reproduce:

Opened firefox on swayWM (Wayland on linux) with the env var GDK_BACKEND=wayland set
I can either:

  • Click on a link on another app (say, Thunderbird)
  • Run xdg-open https//example.com/

Actual results:

In either case, a window that says "Firefox is already running, but not responding" pops up, even though firefox is perfectly responsive. (And it doesn't open the link)

Expected results:

The link should be opened in the existing Firefox instance.

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

I was wrong, the involved env vars were MOZ_ENABLE_WAYLAND=1 and vblank_mode=0

This happens to me also, Firefox 72 under FreeBSD 12.1, vars:
GDK_BACKEND=wayland
CLUTTER_BACKEND=wayland
MOZ_WAYLAND_ENABLE=1

I found a 'fix': Run export $(dbus-launch) before running Sway.
Looks like things need DBus in order to speak to Firefox. Even FF itself.

For me, this only happens if the environment variable enabling native Wayland isn't set for the second Firefox as well.

I think this and bug 1508803 are about the same issue.

Closing, Thanks.

Status: UNCONFIRMED → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1508803
You need to log in before you can comment on or make changes to this bug.