Closed Bug 1589491 Opened 3 years ago Closed 2 years ago

CalDAV: Switching cache mode does not copy username property

Categories

(Calendar :: Provider: CalDAV, defect)

Thunderbird 87
defect
Not set
normal

Tracking

(thunderbird_esr78+ fixed, thunderbird86+ affected, thunderbird87 affected)

RESOLVED FIXED
87 Branch
Tracking Status
thunderbird_esr78 + fixed
thunderbird86 + affected
thunderbird87 --- affected

People

(Reporter: TbSync, Assigned: TbSync)

References

Details

Attachments

(1 file, 1 obsolete file)

In
https://searchfox.org/comm-central/source/calendar/base/src/calCalendarManager.js#672

we must add the new "username" property, which was added in bug 1544596.

Blocks: 1597133

I totally forgot about this.

Assignee: nobody → john
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #9198003 - Flags: review?(philipp)

Mark it as patch.

Attachment #9198003 - Attachment is obsolete: true
Attachment #9198003 - Flags: review?(philipp)
Attachment #9198004 - Flags: review?(philipp)
Attachment #9198004 - Flags: review?(philipp) → review+
Target Milestone: --- → 87 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/3e639553a3b3
Copy username when switching cache mode. r=Fallen

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Uplift to 78?

Comment on attachment 9198004 [details] [diff] [review]
bug1589491_copy_username_when_switching_cache_mode.patch

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined:
Username gets lost on switch between online/offline calendar.

Testing completed (on c-c, etc.):
Risk to taking this patch (and alternatives if risky):
It seems as it will not cause issues, but a try run will follow.

Attachment #9198004 - Flags: approval-comm-esr78?

Comment on attachment 9198004 [details] [diff] [review]
bug1589491_copy_username_when_switching_cache_mode.patch

[Triage Comment]
Approved for esr78

Attachment #9198004 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.