Closed Bug 1589607 Opened 10 months ago Closed 10 months ago

Site specific user agent override stopped working

Categories

(Core :: Networking, defect)

71 Branch
defect
Not set
normal

Tracking

()

RESOLVED INVALID

People

(Reporter: vitaliygrabchuk, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:71.0) Gecko/20100101 Firefox/71.0

Steps to reproduce:

Created settings:
general.useragent.site_specific_overrides = true
general.useragent.override.skype.com = <Chrome UA>

Navigate to web.skype.com

Actual results:

web.skype.com redirects to "Browser not supported" page

Expected results:

Web Skype loads and works correctly.

This worked before Firefox updated to version 71.0b1
Firefox 71.0b1 sends the default user agent instead of override.

Now only global general.useragent.override works and if it is set - override value is used and Web Skype works correctly.

This seems to be by design. see Bug 1513574

Blocks: 1513574
Component: Untriaged → Networking
Product: Firefox → Core

Those prefs were removed from Firefox.
I recommend you use and addon to set the UserAgent on a per-site basis. This one works great and is a verified extension: https://addons.mozilla.org/en-US/firefox/addon/user-agent-string-switcher/?src=search

Status: UNCONFIRMED → RESOLVED
Closed: 10 months ago
Resolution: --- → INVALID

Thanks,
This addon does not allow to create site specific overrides, it modifies user agent for entire browser (or window).
Was site specific useragent overrides feature completely removed and are no longer available even with addon?

Sorry, I can see there is a custom mode in addon options that allows site specific overrides, so ignore previous comment.

Thanks

Duplicate of this bug: 1601109
Duplicate of this bug: 1601305
Duplicate of this bug: 1602876

I now installed this Extension: "User-Agent Switcher and Manager". With this web.skype.com works again. ( https://addons.mozilla.org/de/firefox/addon/user-agent-string-switcher/ )

  1. Go to the plugin's settings and set the radio button to White list mode.
  2. Enter all relevant domains like web.skype.com, skype.com ... as a comma separated list
  3. Select the newest version of e.g. Edge by clicking from the Addon's icon
You need to log in before you can comment on or make changes to this bug.