Closed Bug 1589637 Opened 4 months ago Closed 3 months ago

IsSecureContextOrObjectIsFromSecureContext returns true when Fission on, but expecting false

Categories

(Core :: DOM: Service Workers, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1570243
Fission Milestone M4.1

People

(Reporter: edenchuang, Assigned: edenchuang)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Mochitest dom/serviceworkers/test/test_register_https_in_http.html failed when Fission on.

While calling ServiceWorker API, IsSecureContextOrObjectIsFromSecureContext returns true when Fission on, but expecting false.

IsSecureContextOrObjectIsFromSecureContext might returns wrong value when process boundary changes.

Assignee: nobody → echuang
Fission Milestone: --- → M4
Priority: -- → P2

Roll some unfixed bugs from Fission Milestone M4 to M5

0ee3c76a-bc79-4eb2-8d12-05dc0b68e732

Fission Milestone: M4 → M5

M4.1 because this bug blocks mochitests

Fission Milestone: M5 → M4.1
Pushed by apavel@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/99beb73cff6c
enable mochitest dom/serviceworkers/test/test_register_https_in_http.html for fission r=dom-workers-and-storage-reviewers,perry
Status: NEW → RESOLVED
Closed: 3 months ago
Flags: needinfo?(echuang)
Resolution: --- → DUPLICATE
Duplicate of bug: 1570243
You need to log in before you can comment on or make changes to this bug.