Closed Bug 1589875 Opened 2 years ago Closed 2 years ago

[[Direct3D 11 (Advanced Layers)] ] Browser quit warning dialog / Master Password dialog is empty (The first time is OK) and also About nightly dialog

Categories

(Core :: Graphics, defect)

71 Branch
Desktop
Windows 10
defect
Not set
blocker

Tracking

()

VERIFIED FIXED
Tracking Status
firefox-esr60 --- unaffected
firefox-esr68 --- unaffected
firefox69 --- unaffected
firefox70 --- unaffected
firefox71 --- verified

People

(Reporter: alice0775, Assigned: sotaro)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(6 files)

Attached image image.png

[Tracking Requested - why for this release]: Browser quit warning dialog is empty

Reproducible: always

Steps To Reproduce:
0. Install [ja] build http://archive.mozilla.org/pub/firefox/nightly/2019/10/2019-10-19-09-53-21-mozilla-central-l10n/firefox-71.0a1.ja.win64.zip

  1. Open 3 tabs
  2. Quit Browser ( Ctrl + Shift + Q )
  3. If quit warning dialog is not empty, Cancel it
  4. Repeat Step 2

Actual Results;
Browser quit warning dialog is empty

Expected Results:
Browser quit warning dialog should show properly

Error in Browser Console:

[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: this.L10nRegistry.loadSync :: line 759" data: no] 6 L10nRegistry.jsm:759:19

UpdateUtils.getAppUpdateAutoEnabled - Unable to read app update configuration file. Exception: Win error 2 during operation open on file C:\ProgramData\Mozilla\updates\2DD9109DCD31E5A4\update-config.json (指定されたファイルが見つかりません。

)
[fluent] Missing translations in ja: menu-tools-fxa-sign-in, menu-tools-turn-on-sync, menu-tools-fxa-re-auth. Localization.jsm:202:13

Unknown category for SetEventRecordingEnabled: fxmonitor

No messages returned from https://snippets.cdn.mozilla.net/6/Firefox/71.0a1/2019101909…T_x86_64-msvc/ja/nightly0/Windows_NT%2010.0/default/default/. ASRouter.jsm:137

このキーイベントは一部のキーボードレイアウトでは使用できません: key=“i” modifiers=“accel,alt,shift” id=“key_browserToolbox” browser.xhtml

Summary: [ja] Browser quit warning dialog is empty → [ja] Browser quit warning dialog is empty (The first time is OK)
See Also: → 1589872

I can also reproduce the issue on en-US buid.

Component: Tabbed Browser → Graphics
Product: Firefox → Core
Summary: [ja] Browser quit warning dialog is empty (The first time is OK) → Browser quit warning dialog is empty (The first time is OK)

force enabled WebRender fixes the issue.

Summary: Browser quit warning dialog is empty (The first time is OK) → [[Direct3D 11 (Advanced Layers)] ] Browser quit warning dialog is empty (The first time is OK)

MozRegression:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=7f379c7775ca17056153d034647146b383bb6912&tochange=f6ca531ca5b2f282573ba0e1a9ca0e9f06046ac1

Regressed by: f6ca531ca5b2f282573ba0e1a9ca0e9f06046ac1 Alexis Beingessner — Bug 1573710 - make window resizing more robust to races. r=sotaro

Has Regression Range: --- → yes
Has STR: --- → yes
Regressed by: 1573710
Attached file about:support

Alexis Beingessner [:Gankra],

Your patch seems to cause the regression. Can you please look into this?

Flags: needinfo?(a.beingessner)
Severity: normal → critical
Summary: [[Direct3D 11 (Advanced Layers)] ] Browser quit warning dialog is empty (The first time is OK) → [[Direct3D 11 (Advanced Layers)] ] Browser quit warning dialog / Master Password dialog is empty (The first time is OK)
Severity: critical → blocker
Duplicate of this bug: 1589872
Summary: [[Direct3D 11 (Advanced Layers)] ] Browser quit warning dialog / Master Password dialog is empty (The first time is OK) → [[Direct3D 11 (Advanced Layers)] ] Browser quit warning dialog / Master Password dialog is empty (The first time is OK) and also About nightly dialog

I could reproduce the problem. I take a look.

Flags: needinfo?(a.beingessner)
Assignee: nobody → sotaro.ikeda.g
See Also: → 1589902
Duplicate of this bug: 1589907

Fixed by backed out changeset f6ca531ca5b2 (bug 1573710)

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.