Closed Bug 1589963 Opened 3 months ago Closed 3 months ago

Very long folder names at default storage will breaks Mozilla Firefox usability

Categories

(Core :: Storage: IndexedDB, defect, critical)

71 Branch
x86_64
Windows 7
defect
Not set
critical

Tracking

()

VERIFIED DUPLICATE of bug 1536796

People

(Reporter: Virtual, Unassigned)

Details

(Keywords: nightly-community)

Attachments

(2 files)

STR:

  1. Have installed uBlock Orgin and Gecko Profiler
  2. Update Nightly to latest version
  3. Open uBlock Orgin button menu and see that it opens very slow with very high CPU usage
  4. Open Gecko Profiler button menu to capture profile and see that it doesn't work

There are also massive amount of errors and warnings in Browser Console.

It's not reproducible in new profile in Firefox Portable or when searching for regression with mozregression-gui without profile.

Enabling only Gecko Profiler extension in Add-ons Manager/about:addons produces these errors and warnings in Browser Console.

:Virtual, could you try to find a regression range in using for example mozregression?

Summary: Latest Nightly breaks profile → Very long folder names at default storage will breaks Mozilla Firefox usability

WFM on Nightly 71 20191020094538 on Win10 1903, with installed uBlock Orgin and Gecko Profiler in a clean profile.

Very long folder names at default storage

How to reproduce?

I finally know cause of this madness!
It's caused by very long folder names at default storage.

Probably caused by these STR:

  1. I downloaded all Arthur Conan Doyle texts with "Web Page, complete" mode from this website page - https://wiersze.fandom.com/wiki/Arthur_Conan_Doyle
  2. One of these website pages broke Mozilla Firefox completely:

STR:

  1. Install uBlock Orgin and Gecko Profiler extensions
  2. Close Mozilla Firefox
  3. Create folder with this name:

file++++C++Users+Virtual_ManPL+Desktop+Czerwonym%20szlakiem_E-book%20%20%20Ogr%C3%B3d%20Petenery%20%20%20FANDOM%20powered%20by%20Wikia.htm

in folder located in:

C:\Users\YOUR_WINDOWS_USER_ACCOUNT_NAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOME_SIGNS.default-nightly\storage\default

so in end it will look like:

C:\Users\YOUR_WINDOWS_USER_ACCOUNT_NAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOME_SIGNS.default-nightly\storage\default\file++++C++Users+Virtual_ManPL+Desktop+Czerwonym%20szlakiem_E-book%20%20%20Ogr%C3%B3d%20Petenery%20%20%20FANDOM%20powered%20by%20Wikia.htm

  1. Enjoy borked profile with non properly working extensions, database and storage

(In reply to Virtual_ManPL [:Virtual] 🇵🇱 - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #4)

STR:

  1. Install uBlock Orgin and Gecko Profiler extensions
  2. Close Mozilla Firefox
  3. Create folder with this name:

file++++C++Users+Virtual_ManPL+Desktop+Czerwonym%20szlakiem_E-book%20%20%20Ogr%C3%B3d%20Petenery%20%20%20FANDOM%20powered%20by%20Wikia.htm

in folder located in:

C:\Users\YOUR_WINDOWS_USER_ACCOUNT_NAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOME_SIGNS.default-nightly\storage\default

so in end it will look like:

C:\Users\YOUR_WINDOWS_USER_ACCOUNT_NAME\AppData\Roaming\Mozilla\Firefox\Profiles\SOME_SIGNS.default-nightly\storage\default\file++++C++Users+Virtual_ManPL+Desktop+Czerwonym%20szlakiem_E-book%20%20%20Ogr%C3%B3d%20Petenery%20%20%20FANDOM%20powered%20by%20Wikia.htm

  1. Enjoy borked profile with non properly working extensions, database and storage

No luck to reproduce it.

Severity: blocker → critical
Component: Untriaged → DOM: IndexedDB
Product: Firefox → Core

Oddly, adding manually this folder from STR, it doesn't reproduce issue for me too, even after I re-added all these removed folders, there was 3 of them, which looked kinda "problematic" for me, for having very long names and deep sub-folder placement, as I couldn't backup it properly before starting testing and looking for regression range, due to too long names Windows error after trying to copy whole Mozilla Firefox profile.

Folders which I removed had these names:

file++++C++Users+Virtual_ManPL+Desktop+Czerwonym%20szlakiem_E-book%20%20%20Ogr%C3%B3d%20Petenery%20%20%20FANDOM%20powered%20by%20Wikia.htm

file++++C++Users+Virtual_ManPL+Desktop+Czerwonym%20szlakiem_E-book%20_%20Ogr%C3%B3d%20Petenery%20_%20FANDOM%20powered%20by%20Wikia.html

file++++D++Data+Software-old+Driver+LCD%20Pixel%20Fixer%20--%20fixing%20LCD%20ghosting,%20burn-in,%20and%20stuck%20pixels.htm

in second folder was ".metadata-v2" file and empty "ls" folder
in third folder was ".metadata-v2" file and "ls" folder with "data.sqlite" and "usage" files

Similar issues:

I want to add that using "Clean Recent History..." and selecting "Everything" as "Time range to clear" and selecting all items ("Browser & Download History", "Cookies", "Active Logins", "Cache", "Form & Search History", "Site Preferences", "Offline Website Data") didn't fixed issue. Only removing these 3 folders with very long names fixed issue.

See Also: → 944918, 1267506, 1357294, 1408141

One more thing I forgot to add, that I could still reproduce issue with disabled all extensions and even in Safe Mode.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1536796
You need to log in before you can comment on or make changes to this bug.