Closed Bug 1590024 Opened 6 months ago Closed 5 months ago

Inconsistent expanding behavior of the address bar

Categories

(Firefox :: Address Bar, defect, P3)

Unspecified
Linux
defect
Points:
2

Tracking

()

RESOLVED INVALID

People

(Reporter: brennan.brisad, Unassigned)

References

(Blocks 1 open bug)

Details

Steps to reproduce:

  • Open two tabs
  • Make sure the address bar is focused in both tabs
  • Start alternating between the tabs by slowly clicking with the mouse on the tabs
    • The address bar will not expand
  • Increase the speed of alternating with the tabs with the mouse
    • The address bar will sometimes expand, sometimes not
  • Instead of using the mouse, use the keyboard: Ctrl-PgUp/PgDn
    • The address bar will expand every time

Expected result:
Don't expand the address bar when changing tabs. With the exception of an empty tab, when I switch a tab, it is because I have content loaded into it which I want to read, it very often not because I want to type a new address into it. If the address bar expands when I switch tab, it steals my attention, and it acts as if it wants me to change what I have already inputted there.

Blocks: megabar

Added a reference to megabar, hope that is okay.

Depends on: 1589826
Priority: -- → P3
Priority: P3 → P2

back to p3 since we're fixing bug 1589826

Points: --- → 2
Priority: P2 → P3

Bug 1589826 removes the collapsed state, so this is no longer an issue. The megabar will now stay expanded the whole time.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.