Closed Bug 1590069 Opened 10 months ago Closed 7 months ago

usocial.pro social media buttons are missing when fingerprinting blocking or TP is enabled

Categories

(Core :: Privacy: Anti-Tracking, defect)

71 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox69 --- affected
firefox70 --- affected
firefox71 --- affected

People

(Reporter: peter.magyari, Unassigned)

References

(Blocks 2 open bugs)

Details

Attachments

(1 file)

Attached image 2019-10-21143016.jpg

[Steps to reproduce]

  1. Go to about:preferences#privacy and from the Custom section uncheck all the boxes except for "Fingerprinters"
  2. Navigate to https://www.ucoz.ru/all/

[Expected result]

Social media buttons should not be blocked

[Actual result]

Social media buttons disappear when Fingerprinters are set to be blocked

This is due to us blocking the embed script from usocial.pro. Specifically https://usocial.pro/usocial/usocial.js?js=1.7.0.

Blocks: tp-breakage
Summary: Missing social media buttons when fingerprinters are blocked → usocial.pro social media buttons are missing when fingerprinting blocking or TP is enabled

The fingerprinting code is present in https://usocial.pro/usocial/fingerprint2.min.js. However, blocking this script appears to block the load of the social buttons.

We've decided to accept this breakage.

Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.