Closed Bug 1590151 Opened 3 months ago Closed 3 months ago

Crash in [@ core::result::unwrap_failed]

Categories

(Core :: Audio/Video: cubeb, defect, P2, critical)

Desktop
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- unaffected
firefox72 --- fixed

People

(Reporter: marcia, Assigned: chunmin)

References

(Blocks 1 open bug)

Details

(Keywords: crash, regression)

Crash Data

Attachments

(2 files)

This bug is for crash report bp-b748c7c1-f0a7-422d-baf3-2eb410191021.

Seen while looking at nightly crash stats - macOS and Linux crash which started in 20191003214801: https://bit.ly/2P7VrVu

Crashes in 71 all macOS have Moz Crash reason: called Result::unwrap() on an Err value: Error { code: Error } or Linux called Result::unwrap() on an Err value: Os { code: 13, kind: PermissionDenied, message: "Permission denied" }

Possible regression range based on build ID: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=cb9bbf38fa45ad65e3016495455e216f69f57ba0&tochange=2e1bfb7458de41a36432671c405eee62d897a761

Top 10 frames of crashing thread:

0 XUL gkrust_shared::panic_hook mfbt/Assertions.h:332
1 XUL core::ops::function::Fn::call src/libcore/ops/function.rs:69
2 XUL std::panicking::rust_panic_with_hook src/libstd/panicking.rs:481
3 XUL std::panicking::continue_panic_fmt src/libstd/panicking.rs:384
4 XUL rust_begin_unwind src/libstd/panicking.rs:311
5 XUL core::panicking::panic_fmt src/libcore/panicking.rs:85
6 XUL core::result::unwrap_failed src/libcore/macros.rs:18
7 XUL cubeb_coreaudio::backend::audiounit_get_devices_of_type src/libcore/result.rs:800
8 XUL coreaudio_sys_utils::dispatch::create_closure_and_executor::closure_executer media/libcubeb/cubeb-coreaudio-rs/coreaudio-sys-utils/src/dispatch.rs:59
9  @0x7fff6fb0b4dd 

The one on Linux are something else, and are related to Web Render. The one on macOS is a bug in Chunmin's new backend.

Assignee: nobody → cchang
Priority: -- → P2

From the crash report, it seems like there is a core::result::unwrap_failed in audiounit_get_devices_of_type. So I guess the code explodes here. get_channel_count is unwrapped without checking its result.

However, I am not sure what would make it happen.

Adding 71 as affected since this crash started on macOS right before the merge and there are macOS crashes in 71.

(In reply to Marcia Knous [:marcia - needinfo? me] from comment #3)

Adding 71 as affected since this crash started on macOS right before the merge and there are macOS crashes in 71.

We only try this new backend in Nightly so this crash only happens in Nightly. They won't affect the release version.

Attached file GitHub Pull Request
Blocks: 1530713

I just had this on OSX 10.15, unplugging my headset as a youtube video was starting up. The headset was plugged into the 1/8" audio jack. MacBook Air (Retina, 13-inch, 2018). Graphics: Intel UHD Graphics 617 1536 MB. Nightly 72.0a1 (2019-10-31) (64-bit).

Pick commits:
cd954ca - Update dependencies (#22)
7043a0c - Make audiounit_get_devices_of_type infallible (#21)

Pushed by rmaries@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/268a241e5651
Update cubeb-coreaudio-rs to cd954ca. r=padenot
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/a8d5b5b537ce
Update Cargo.lock to fix broken SM builds. r=eijebong CLOSED TREE
Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Tentative QE+ ;we might be able to reproduce the crash with our workstations as well.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.