Closed Bug 1590394 Opened 3 years ago Closed 3 months ago

[wayland/kde?] Window decorations incorrect with title bar disabled

Categories

(Core :: Widget: Gtk, defect)

70 Branch
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: tom, Unassigned, NeedInfo)

References

(Blocks 2 open bugs)

Details

Attachments

(2 files)

Attached image Screenshot of problem

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

On wayland KDE:

  1. Start firefox with wayland enabled: MOZ_ENABLE_WAYLAND=1 firefox
  2. Go to menu > customize
  3. Untick "Title Bar" at the bottom

(This may affect other desktop environments, I only have KDE to test with)

Actual results:

It mostly works, but there are two problems

  1. There is a gap drawn around the window (see screenshot, it's tiled and kwin does not add those gaps, the firefox window forces it. They are not there using X firefox even on Xwayland)

  2. The maximize and minimize buttons are missing from the titlebar

Expected results:

  1. The window should be drawn without a gap around the edges
  2. The minimize and maximize buttons should appear.

Looking online, this suggests Firefox is running in "Tablet mode" so if there's a way to force disable that, it might be an easy fix/workaround.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

This issue still exists on Firefox 101.0.1. In my case, I'm running MATE in X with Compiz, so Wayland might not be related.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:101.0) Gecko/20100101 Firefox/101.0
Reproduced with the same steps originally posted, minus Wayland.

Thanks. Do you see this bug with other Gtk apps, like gedit?

Flags: needinfo?(tom)
Flags: needinfo?(commenterofcomments)
Attached image Marco bugginess

At the time I posted that, I had only seen this occur with Firefox. However, since then, I found the same issue in ungoogled-chromium. I tested gedit since you mentioned it in particular, and it happens there as well. I also tried Marco (mate's default window manager) instead of Compiz, and it... usually doesn't suffer this issue? There were rare occasions where it would bug out and place window decoration with a large gap around Firefox, despite disabling title bar in Firefox settings. Compiz would consistently place a gap around Firefox, and the title bar would frequently appear despite my settings, however I selectively disabled window decoration for Firefox in Compiz settings to get around that. I'm unsure if this issue is related to Firefox at all, although I don't know where this could even be reported.

Ironically, as I was typing this, the rare Marco issue I mentioned happened again. I can't produce it consistently, re-enabling title bar in Firefox settings will act normally without a gap. I've attached a screenshot of this issue occurring on my personal setup.

Flags: needinfo?(commenterofcomments)

Thanks for testing. Looks like window manager can't work with window extents. Nothing to fix on Firefox side so closing.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.