Closed Bug 1590430 Opened 3 months ago Closed 3 months ago

firefox 71 not starting windows 8

Categories

(Firefox :: General, defect, P1, critical)

71 Branch
x86_64
Windows 8
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
relnote-firefox --- 71+
firefox70 --- unaffected
firefox71 + affected

People

(Reporter: sepehr.ha, Assigned: toshi)

References

(Regression)

Details

(Keywords: crash, regression)

Attachments

(3 files)

7.87 KB, application/octet-stream
Details
12.63 KB, text/plain
Details
250.04 KB, application/x-msdownload
Details
Attached file Report.wer

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3865.120 Safari/537.36

Steps to reproduce:

last time my firefox developer edition updated , it is not starting any more!
just windows crash report .

Actual results:

when i check task manager firefox crash/exit after i click on icon or exe . then immediately windows crash report starts ! here is the logs from event viewer:

Faulting application name: firefox.exe, version: 71.0.0.7233, time stamp: 0x5dadf568
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0xc0000005
Fault offset: 0x000007fcc590012a
Faulting process id: 0x9428
Faulting application start time: 0x01d588e9030a8343
Faulting application path: C:\Program Files\Firefox Developer Edition\firefox.exe
Faulting module path: unknown
Report Id: 413e7a84-f4dc-11e9-8280-0024beb658da
Faulting package full name:
Faulting package-relative application ID:

what i try :
uninstall/install again ( latest version downloaded from Firefox site. )
delete profile folder and test again .

but i tested an older version 70.0b9 and it is working !!!!(http://archive.mozilla.org/pub/devedition/releases/70.0b9/win64/en-US/Firefox%20Setup%2070.0b9.exe).

Expected results:

Firefox should start !!

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Installer
Component: Installer → General

Could you try the https://mozilla.github.io/mozregression/ to find the regression range?

Severity: normal → critical
Has Regression Range: --- → no
Has STR: --- → no
Flags: needinfo?(sepehr.ha)
OS: Unspecified → Windows 8
Hardware: Unspecified → x86_64

Tracking for 71

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

(In reply to YF (Yang) from comment #2)

Could you try the https://mozilla.github.io/mozregression/ to find the regression range?

Here We go !

2019-10-23T15:40:15: INFO : Running autoland build built on 2019-09-23 23:35:11.738000, revision e0fbad31
2019-10-23T15:40:18: INFO : Launching c:\Users\Black\AppData\Local\temp\tmpdgrysy\firefox\firefox.exe
2019-10-23T15:40:18: INFO : Application command: c:\Users\Black\AppData\Local\temp\tmpdgrysy\firefox\firefox.exe --allow-downgrade --wait-for-browser -profile c:\users\black\appdata\local\temp\tmpxabnye.mozrunner
2019-10-23T15:40:19: INFO : application_buildid: 20190923202157
2019-10-23T15:40:19: INFO : application_changeset: e0fbad31951f5bfd5be935cfff1dd0689f84ad91
2019-10-23T15:40:19: INFO : application_display_name: Firefox Nightly
2019-10-23T15:40:19: INFO : application_id: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
2019-10-23T15:40:19: INFO : application_name: Firefox
2019-10-23T15:40:19: INFO : application_remotingname: firefox
2019-10-23T15:40:19: INFO : application_repository: https://hg.mozilla.org/integration/autoland
2019-10-23T15:40:19: INFO : application_vendor: Mozilla
2019-10-23T15:40:19: INFO : application_version: 71.0a1
2019-10-23T15:40:19: INFO : platform_buildid: 20190923202157
2019-10-23T15:40:19: INFO : platform_changeset: e0fbad31951f5bfd5be935cfff1dd0689f84ad91
2019-10-23T15:40:19: INFO : platform_repository: https://hg.mozilla.org/integration/autoland
2019-10-23T15:40:19: INFO : platform_version: 71.0a1
2019-10-23T15:40:23: WARNING : Process exited with code 255
2019-10-23T15:40:28: INFO : Narrowed inbound regression window from [1d2de2fa, 56c82d00] (3 builds) to [1d2de2fa, e0fbad31] (2 builds) (~1 steps left)
2019-10-23T15:40:28: DEBUG : Starting merge handling...
2019-10-23T15:40:28: DEBUG : Using url: https://hg.mozilla.org/integration/autoland/json-pushes?changeset=e0fbad31951f5bfd5be935cfff1dd0689f84ad91&full=1
2019-10-23T15:40:30: DEBUG : Found commit message:
Bug 1542830: Part 8 - Rename the "untrustedModules" ping to "third-party-modules" and change the schema to support multiprocess; r=janerik

Note that to avoid introducing errors, I elected against renaming everything in
the code; internally to Firefox the code still refers to "UntrustedModules";
only the relevant fields have been renamed to reference the new ping schema.

A PR for backend schema changes is in the works.

Depends on D43161

Differential Revision: https://phabricator.services.mozilla.com/D43162

2019-10-23T15:40:30: DEBUG : Did not find a branch, checking all integration branches
2019-10-23T15:40:30: INFO : The bisection is done.
2019-10-23T15:40:30: INFO : Stopped

Flags: needinfo?(sepehr.ha)
Has Regression Range: no → yes
Has STR: no → ---
Regressed by: 1542830

Aaron, your patch in bug 1542830 seems to have caused this regression, could you investigate please? Thanks

Flags: needinfo?(aklotz)

Bogdan, would it be possible for your team to test if you can reproduce this crash in Windows? I'd like to know if this is a common issue or an edge case for people updating Firefox. Thanks

Flags: needinfo?(bogdan.maris)

Stealing this from Bogdan as I was already investigating.
I tried to reproduce on Windows 8 Pro (x32) and Windows 8.1 (x32) but couldn't reproduce the crashes.
Both installing the latest DevEdition 71 or upgrading it from 70 worked fine.
Do you have any unsubmitted crash reports or events created in "C:\Users\User\AppData\Roaming\Mozilla\Firefox\Profiles\bd609ed8.test111\crashes"? If yes, attach them here.

Please try to run firefox with a new profile using the instructions provided in: https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles and let us know if that helped with anything.

Flags: needinfo?(bogdan.maris) → needinfo?(sepehr.ha)

I tried to run Firefox with a new profile and profile manager is not opening too.
I also tried to rename profile folder and i expected to see error "profile folder not exist" ! but it crashed before that!

I also confirm that now my Firefox (NOT DevEdition) updated to 71.0b3, and it is working. but DevEdition still crashing!
I also tried nightly (72.0a1) version and i confirm it is working too!

Also checked crashes folder in profile and nothing there!

Attached systeminfo output , maybe it helps!

Flags: needinfo?(sepehr.ha)
Attached file system info

What are you running for antivirus software?

Flags: needinfo?(aklotz) → needinfo?(sepehr.ha)

symantec antivirus, i also suspected that and disabled all from settings , and added exception for firefox but nothing changed!

Flags: needinfo?(sepehr.ha)
Priority: -- → P1

Any news? now i can only use Firefox nightly !
Firefox and Firefox DevEdition not working anymore for me !!! :(
last time Firefox 71.03 worked after update but now after reboot it crashed like DevEdition :(

Update!
Found something , i figured out one dll is loading after Firefox that is not normal !
C:\Windows\system32\IseGuard64.dll
It is listed in windows report i attached first!
Searched google and it is related to comodo ! but in my life i never ever installed comodo or any related software !! :)
I dont know where it comes from , but when i removed it everything started working !!!
Also submitted to virus-total and 0 result!
Maybe it helps other people with the same problem!
I attached the dll !

Attached file iseguard64.dll
Assignee: nobody → tkikuchi

I installed the latest Comodo Antivirus, but Firefox Dev Edition was launched successfully. I confirmed IseGuard64.dll was injected into firefox.exe on my test environment, but its version was 1.6.13835.185, while the version of IseGuard64.dll attached to this bug is 1.2.31435.94. So maybe this crash problem happened with an older version of Comodo Antivirus.

I also found a similar issue on https://support.mozilla.org/en-US/questions/1271104, where Firefox 71.0.0.7233 crashed with Comodo Firewall. And in that case, the reporter said FF started to work after updating Comodo.

Given that the issue was solved after removing comodo software, I'm closing this as WORKSFORME. If you start hitting the same issue again, please feel free to reopen this bug.

Status: NEW → RESOLVED
Closed: 3 months ago
Resolution: --- → WORKSFORME

Maybe worth release noting, since many of the replies in SUMO say that removing the (leftover) Comodo related files worked. Pascal, what do you think? Want to add it as a known issue? There may be something in 71 that changed that makes more people hit this problem.

Flags: needinfo?(pascalc)

(In reply to Liz Henry (:lizzard) from comment #18)

Maybe worth release noting, since many of the replies in SUMO say that removing the (leftover) Comodo related files worked. Pascal, what do you think? Want to add it as a known issue? There may be something in 71 that changed that makes more people hit this problem.

OK to release note it but I don't have a good wording at hand, any suggestion?

Flags: needinfo?(pascalc)

Some Windows users who had previously installed and uninstalled Comodo antivirus software may not be able to start Firefox. Information on how to resolve this issue is described on support.mozilla.org (Link to knowledgebase article TBD since I haven't written it yet, n-i on myself to do this later today)

Flags: needinfo?(lhenry)

Added to release notes as:

Some Windows users who had previously installed and uninstalled Comodo antivirus software may not be able to start Firefox. Information on how to resolve this issue is described on support.mozilla.org or in the support knowledgebase.

Flags: needinfo?(lhenry)
Duplicate of this bug: 1602341

A user reporting this issue with only Comodo Backup installed and not AntiVir:

https://www.reddit.com/r/firefox/comments/e942x4/issue_about_firefox_not_launching_at_all/fagk9m0/

Dll version: 1, 1, 413499, 43

Hmm, I installed Comodo Backup from https://www.comodo.com/home/backup-online-storage/backup-first-time-setup.php, but iseguard64.dll was not installed. Maybe it was bundled with another application the user was not aware of.

You need to log in before you can comment on or make changes to this bug.