Closed Bug 1590997 Opened 2 years ago Closed 2 years ago

Set MediaRecorder's mimeType async after start()

Categories

(Core :: Audio/Video: Recording, defect, P2)

71 Branch
defect

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox-esr68 --- unaffected
firefox70 --- unaffected
firefox71 --- fixed
firefox72 --- fixed

People

(Reporter: pehrsons, Assigned: pehrsons)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

In bug 1512175 we landed new mimeType behavior that was up to spec.

The spec is about to change in PR #190 to set the mimeType async just before firing "start".

This matches our old (pre-71) behavior better. We should defer setting the mimeType per the new proposal to avoid flip-flopping this behavior between 70-71-72 (assuming the spec change lands and our fixes land in 72), considering the annoyances such changes would bring to developers.

The spec PR has been merged.

Andreas, what are your plans wrt to 71? Any uplift needed?

Flags: needinfo?(apehrson)

Yes, the fix will be quite simple and I'd much prefer to get it uplifted to 71. I just need to dig up some time to write it.

Flags: needinfo?(apehrson)

Andreas, when do you plan to land a patcha and request an uplift to beta? We are at beta 8 out of 12. Thanks.

Flags: needinfo?(apehrson)

Yep, sorry. I've been bogged down by other work. I'll try to get this prioritized.

Flags: needinfo?(apehrson)
Pushed by pehrsons@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/42f9a49ed38f
Update tests for new MediaRecorder mimetype-at-start-event behavior. r=jib
https://hg.mozilla.org/integration/autoland/rev/550c2f8bde45
Defer setting MediaRecorder mimeType attribute until firing start event. r=jib
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/20171 for changes under testing/web-platform/tests
Upstream web-platform-tests status checks passed, PR will merge once commit reaches central.
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Upstream PR merged by moz-wptsync-bot

Comment on attachment 9107347 [details]
Bug 1590997 - Defer setting MediaRecorder mimeType attribute until firing start event. r?jib

Beta/Release Uplift Approval Request

  • User impact if declined: We ship new behavior for MediaRecorder in 71 that we immediately in 72 return back to being on par with pre-71.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No threading changes, no lifetime changes. We're just moving the setting of a member on main thread to a later point in time. The biggest risk I see is in setting the member when we're not supposed to, because the class has already been reset. However we are handling such cases explicitly so I still consider that low risk.
  • String changes made/needed:
Attachment #9107347 - Flags: approval-mozilla-beta?
Attachment #9107346 - Flags: approval-mozilla-beta?

Comment on attachment 9107347 [details]
Bug 1590997 - Defer setting MediaRecorder mimeType attribute until firing start event. r?jib

Low risk Mediarecorder change with tests, uplift approved for 71 beta 9, thanks.

Attachment #9107347 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attachment #9107346 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.