Closed Bug 1591006 Opened Last month Closed Last month

Re-arrange browser-chrome tests by using domains as subfolders

Categories

(Remote Protocol :: Agent, task, P1)

Tracking

(firefox72 fixed)

RESOLVED FIXED
Tracking Status
firefox72 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

References

(Regressed 1 open bug)

Details

User Story

Please see the following documentation in how to get started with the Remote Protocol project:
https://firefox-source-docs.mozilla.org/remote/

Here some information in how to work with the repository:
https://mozilla-version-control-tools.readthedocs.io/en/latest/hgmozilla/unifiedrepo.html

Attachments

(1 file, 1 obsolete file)

Similar to the Input domain tests which already have been moved to the input subfolder, we should do the same for all the other existent browser-chrome tests under the following folder:

https://searchfox.org/mozilla-central/source/remote/test/browser/

For example browser_page_captureScreenshot.js would have to be moved under the page subfolder, and renamed to browser_captureScreenshot.js.

Please check the user story field above for details in how to get started. If something is missing don't hesitate to ask.

Mentor: mjzffr
Whiteboard: [lang=js]

(Adding a language to the whiteboard, as above, makes a bug show up on https://codetribute.mozilla.org. Setting the Mentor field alone isn't enough, looks like.)

Sorry for picking this from the mentored bugs but I would like to see a better structure before I get started with new features and tests.

Assignee: nobody → hskupin
Mentor: hskupin, mjzffr
Status: NEW → ASSIGNED
Keywords: good-first-bug
Whiteboard: [lang=js]
Priority: -- → P1
Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3070efa26503
[remote] Re-arrange browser-chrome tests by domains as subfolders. r=remote-protocol-reviewers,maja_zf
Attachment #9105075 - Attachment is obsolete: true
Status: ASSIGNED → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Regressions: 1593979
You need to log in before you can comment on or make changes to this bug.