Closed Bug 1591007 Opened 3 months ago Closed 2 months ago

"Save Changes" in "Manage Data" dialog in preferences doesn't close the dialog

Categories

(Firefox :: Preferences, defect, P3)

70 Branch
Unspecified
All
defect

Tracking

()

RESOLVED FIXED
Firefox 72
Tracking Status
firefox72 --- fixed

People

(Reporter: red-fox0, Assigned: stensonj, Mentored)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

  1. about:preferences#privacy
  2. click "Manage Data…" in section "Cookies and Site Data".
  3. do nothing and delete nothing (!)
  4. click "Save Change"

Actual results:

Widget did not close.

Expected results:

Closed widget

Summary: [UI] Preferences. Button "Save Change" not close widget → [UI] Preferences. Button "Save Change" not close widget [firefox 70.0]

Bugbug thinks this bug should belong to this component, but please revert this change in case of error.

Component: Untriaged → Preferences

Not a regression.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Keywords: dupeme

Johann, what is this /supposed/ to do?

Flags: needinfo?(jhofmann)
Summary: [UI] Preferences. Button "Save Change" not close widget [firefox 70.0] → "Save Changes" in "Manage Data" dialog in preferences doesn't close the dialog

Huh, good question, I would say it should close. Seems like a good mentored bug. Not aware of any dupes, but maybe I'm wrong.

Mentor: jhofmann
Flags: needinfo?(jhofmann)
Keywords: dupeme
Priority: -- → P3

Hi there, I would like to take on this bug. I am new to debugging mozilla code and also new to bugzilla so I may need some guidance completing it if that is okay. Could you give me an idea as to which file I would need to edit to fix this bug? Thanks

Flags: needinfo?(red-fox0)

(In reply to Jacob Stenson from comment #5)

Hi there, I would like to take on this bug. I am new to debugging mozilla code and also new to bugzilla so I may need some guidance completing it if that is okay. Could you give me an idea as to which file I would need to edit to fix this bug? Thanks

Best needinfo the mentor rather than the reporter. It so happens Johann is out, so I'll step in for the moment.

In https://searchfox.org/mozilla-central/rev/e7c61f4a68b974d5fecd216dc7407b631a24eb8f/browser/components/preferences/siteDataSettings.js#265-291, allowed starts out as false and is never set to true if there are no items to remove. Does that help?

Mentor: jhofmann → gijskruitbosch+bugs
Flags: needinfo?(red-fox0) → needinfo?(stensonj)
if (removals.length) {
    //…
} else {
    //nothing
    allowed = true; 
}

Right?

Thank you for stepping in for Johann. Yes that appears to help. I will start work on fixing this and get back to you. Thanks a lot.

Flags: needinfo?(stensonj)

I believed I have solved the issue. Heading to about:preferences#privacy then going to "Manage Data…" in the "Cookies and Site Data" section. After changing no settings I click "Save Changes" and the widget closes.
What are the next steps for me to get this code commited, reviewed and completed? Sorry to ask for help on every step, I am very new to this. I appreciate the help.

Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/2eaeb35d81d6
Save Changes in Manage Data dialog in preferences doesn't close the dialog, r=Gijs

Looks like you figured it out - thanks!

Assignee: nobody → stensonj
Flags: needinfo?(gijskruitbosch+bugs)

Thank you. Do I need to do anything else?

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WORKSFORME

(In reply to Jacob Stenson from comment #13)

Thank you. Do I need to do anything else?

Nope. The bug will get closed automatically once the change is merged to mozilla-central, so leaving it open for now.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Ah okay, apologies for closing it prematurely.

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 72
QA Whiteboard: [good first verify]
You need to log in before you can comment on or make changes to this bug.