Closed Bug 1591209 Opened 6 months ago Closed 5 months ago

Add JSFunction::baseScript()

Categories

(Core :: JavaScript Engine, task, P1)

task

Tracking

()

RESOLVED FIXED
mozilla72
Tracking Status
firefox72 --- fixed

People

(Reporter: tcampbell, Assigned: tcampbell)

References

Details

Attachments

(1 file)

In order to move towards JSFunction not storing the LAZY_INTERPRETED flag, it is helpful to add a JSFunction::baseScript accessor when the info being queried is defined on either. This also means we can avoid forcing delazification in cases we don't care about and reserve it for cases that we do (such as being ready to execute).

Add a baseScript() accessor to use in cases where to accessor properties
through a JSFunction that are defined for both lazy and non-lazy
scripts.

Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ce39fc80bb5b
Add JSFunction::baseScript() accessor. r=jandem
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72

Backed out changeset ce39fc80bb5b (bug 1591209) due to perf/memory regressions at tcampbell request.

Backout: https://hg.mozilla.org/integration/autoland/rev/88d98643f874655565c32847817b487f0c6509ba

Status: RESOLVED → REOPENED
Flags: needinfo?(tcampbell)
Resolution: FIXED → ---
Target Milestone: mozilla72 → ---
Attachment #9104061 - Attachment description: Bug 1591209 - Add JSFunction::baseScript() accessor. → Bug 1591209 - Add JSFunction::baseScript() accessor. r=jandem
Pushed by tcampbell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a30412eb09b5
Add JSFunction::baseScript() accessor. r=jandem
Status: REOPENED → RESOLVED
Closed: 5 months ago5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla72
Regressions: 1592612
Flags: needinfo?(tcampbell)
You need to log in before you can comment on or make changes to this bug.