Closed Bug 1591874 Opened 9 months ago Closed 7 months ago

Move VariablesView files to devtools/client/storage

Categories

(DevTools :: Storage Inspector, task, P3)

task

Tracking

(firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
firefox73 --- fixed

People

(Reporter: nchevobbe, Assigned: nchevobbe)

References

Details

Attachments

(1 file)

After Scratchpad removal, the storage inspector will be the last consumer of the VariableView.
Let's move it to the storage inspector folder so it's obvious it does not have any other consumers.

Assignee: nobody → nchevobbe
Status: NEW → ASSIGNED
Component: Shared Components → Storage Inspector

Since the storage inspector is the last consumer of the VariablesView,
it makes sense to move the component directly in the storage inspector
folder.
Since it can't have a controller, the bits where we were checking this
are removed.

Depends on D54733

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6dc649a6a711
Move VariablesView files to devtools/client/storage. r=miker.

sorry, there was something wrong in how I moved the file.
I updated the patch and pushed to TRY to make sure everything is okay

Flags: needinfo?(nchevobbe)
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0b5282256e00
Move VariablesView files to devtools/client/storage. r=miker.

Backed out 2 changesets (Bug 1529917, Bug 1591874) for causing bustages in VariablesView.jsm

Backout link: https://hg.mozilla.org/integration/autoland/rev/4cf52729f132bf19c9465044d4f0e14b9cca25de

Push with failures: https://treeherder.mozilla.org/#/jobs?repo=autoland&collapsedPushes=598800&tochange=4cf52729f132bf19c9465044d4f0e14b9cca25de&fromchange=0b5282256e0094eeae41d6c6377c6b37893cbf06&selectedJob=279319506

Failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=279319506&repo=autoland&lineNumber=1390

[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - mozbuild.frontend.reader.SandboxValidationError:
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - ==============================
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - FATAL ERROR PROCESSING MOZBUILD FILE
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - ==============================
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - The error occurred while processing the following file or one of the files it includes:
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - /builds/worker/workspace/build/src/devtools/client/storage/moz.build
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - The error occurred when validating the result of the execution. The reported error is:
[task 2019-12-03T13:23:07.427Z] 13:23:07 INFO - File listed in FINAL_TARGET_FILES does not exist: /builds/worker/workspace/build/src/devtools/client/storage/VariablesView.jsm

Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/faeca320475a
Move VariablesView files to devtools/client/storage. r=miker.
Pushed by archaeopteryx@coole-files.de:
https://hg.mozilla.org/integration/autoland/rev/a7f97f586d04
Move VariablesView files to devtools/client/storage. r=miker.
Pushed by nchevobbe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3835aab3ce21
Move VariablesView files to devtools/client/storage. r=miker.
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73
Duplicate of this bug: 1603792
You need to log in before you can comment on or make changes to this bug.