Closed Bug 1591908 Opened 1 year ago Closed 9 months ago

Limit tooltip for WS payload in Messages panel

Categories

(DevTools :: Netmonitor, defect, P2)

defect

Tracking

(firefox75 fixed)

RESOLVED FIXED
Firefox 75
Tracking Status
firefox75 --- fixed

People

(Reporter: Honza, Assigned: vtsty.dev)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(3 files)

Tooltips in the Messages panel (displaying WS payload) can be too big. Let's introduce a logic that limits them.

Honza

STR:

  1. Load https://socket.io/
  2. Select the Network panel and reload the page
  3. Set the WS filter button in the Toolbar to make it easier to find 101 requests
  4. Select the 101 request and look at the Messages panel
  5. Wait for a frame with bigger payload body
  6. Hover over the raw in the WS frame list -> displayed tooltip is big and broken -> BUG

Honza

Attached image image.png

See the attached screenshot showing broken tooltip.
Honza

Some instructions for anyone interested in fixing this bug:

  1. The fix can be very similar to what we did for the Search panel tooltips.
    https://phabricator.services.mozilla.com/D47516

  2. Here is where the tooltip is rendered
    https://searchfox.org/mozilla-central/rev/74cc0f4dce444fe0757e2a6b8307d19e4d0e0212/devtools/client/netmonitor/src/components/websockets/FrameListColumnData.js#33

Honza

Keywords: good-first-bug
Has STR: --- → yes

:Honza, if you think that's a regression, then could you try to find a regression range in using for example mozregression?

Hi @Honza. Can I take up this issue?

Assignee: nobody → vtsty.dev
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 75
Flags: qe-verify+
Attached image Nightly_76.png

I can still reproduce this issue on Ubuntu 18.04 with the latest Nightly (see the attached screenshot)

Looking at the screenshot, the tooltip is big but, not broken correct?
According to the last three dots (...) in the tooltip, it looks like the patch is properly applied.
Honza

Flags: needinfo?(anca.soncutean)

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #10)

Looking at the screenshot, the tooltip is big but, not broken correct?

Correct, I was focusing on the size of the tooltip there, but while most of them end with (..) I can still see tooltips like the following: https://drive.google.com/file/d/1fRktNDja0Cll69zQrneUoJBc5ehjBlVz/view?usp=sharing

Flags: needinfo?(anca.soncutean) → needinfo?(odvarko)

Ah, I see it on the screenshot now. So, yes, this looks like a bug.
Can you please file a follow up bug, this should be fixed.

Thanks,
Honza

Flags: needinfo?(odvarko) → needinfo?(anca.soncutean)

(In reply to Jan Honza Odvarko [:Honza] (always need-info? me) from comment #12)

Ah, I see it on the screenshot now. So, yes, this looks like a bug.
Can you please file a follow up bug, this should be fixed.

Thanks,
Honza

Filled bug 1626189!

Flags: needinfo?(anca.soncutean)
Regressions: 1626189
You need to log in before you can comment on or make changes to this bug.