Closed Bug 1591974 Opened 3 years ago Closed 3 years ago

Crash in [@ __pthread_mutex_lock]

Categories

(Core :: General, defect)

x86
Linux
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 1581121

People

(Reporter: lizzard, Unassigned)

References

Details

(Keywords: crash)

Crash Data

This bug is for crash report bp-d56e1a72-167b-4eaf-abcf-c79e90191028.

Top crash in 70 on release for Linux, with about 3 times the volume this signature had in 69 release.

Top 10 frames of crashing thread:

0 libpthread-2.23.so __pthread_mutex_lock /build/glibc-GoSbp4/glibc-2.23/nptl/../nptl/pthread_mutex_lock.c:67
1 firefox firefox@0xba02 
2 firefox firefox@0xb9cf 
3 libxul.so libxul.so@0x748448b 
4 libxul.so libxul.so@0x4afafd5 
5 libxul.so libxul.so@0x748448b 
6 libxul.so libxul.so@0x4cabbad 
7 libxul.so libxul.so@0x748448b 
8 libxul.so libxul.so@0x74a11d7 
9 libxul.so libxul.so@0x748448b 

I just had a look at this now that we have proper symbols for those crashes. There's at least two different stack, one for x86-64 which looks bogus and covers only a minority of reports and one for x86. The latter is much more common and looks like this:

0 	libpthread-2.23.so 	__pthread_mutex_lock 	/build/glibc-GoSbp4/glibc-2.23/nptl/../nptl/pthread_mutex_lock.c:67 	context
1 	firefox 	free 	/build/firefox-oG_HF4/firefox-70.0.1+build1/memory/build/malloc_decls.h:41 	cfi
2 	libxul.so 	core::ptr::real_drop_in_place 	/usr/src/rustc-1.36.0/src/libcore/ptr.rs:195 	cfi
3 	libxul.so 	style::gecko::wrapper::get_animation_rule 	/build/firefox-oG_HF4/firefox-70.0.1+build1/servo/components/style/gecko/wrapper.rs:1008 	cfi
4 	libxul.so 	style::matching::PrivateMatchMethods::replace_rules_internal 	/build/firefox-oG_HF4/firefox-70.0.1+build1/servo/components/style/matching.rs:174 	cfi
5 	libxul.so 	style::traversal::compute_style 	/build/firefox-oG_HF4/firefox-70.0.1+build1/servo/components/style/traversal.rs:634 	cfi
6 	libxul.so 	geckoservo::glue::traverse_subtree 	/build/firefox-oG_HF4/firefox-70.0.1+build1/servo/ports/geckolib/glue.rs:263 	cfi
7 	libxul.so 	Servo_TraverseSubtree 	/build/firefox-oG_HF4/firefox-70.0.1+build1/servo/ports/geckolib/glue.rs:313 	cfi
8 	libxul.so 	StyleDocument 	/build/firefox-oG_HF4/firefox-70.0.1+build1/layout/style/ServoStyleSet.cpp:768 	cfi
9 	libxul.so 	DoProcessPendingRestyles 	/build/firefox-oG_HF4/firefox-70.0.1+build1/layout/base/RestyleManager.cpp:3058 	cfi
10 	libxul.so 	DoFlushPendingNotifications 	/build/firefox-oG_HF4/firefox-70.0.1+build1/layout/base/PresShell.cpp:4127 	cfi

Looking at frames 2 and 3 since all crashes with this stack are coming from 32-bit Ubuntu this really looks like bug 1581121 so I think we should dupe against that.

Also the __pthread_mutex_lock in the first frame is hiding the real cause, we should probably add it to the prefix list so that it doesn't stop signature generation.

OK, now we're getting real stack signatures that tells this crash apart from the others. This does indeed look like bug 1581121, I'll wait another couple of days just to be sure and then we can dup it.

Crash Signature: [@ __pthread_mutex_lock] → [@ __pthread_mutex_lock] [@ __pthread_mutex_lock | free | core::ptr::real_drop_in_place | servo_arc::Arc<T>::drop_slow] [@ __pthread_mutex_lock | free | core::ptr::real_drop_in_place | style::gecko::wrapper::get_animation_rule] [@ __pthread_mutex_lock …

The priority flag is not set for this bug.
:nhi, could you have a look please?

For more information, please visit auto_nag documentation.

Flags: needinfo?(nhnguyen)

:gsvelto, do we have enough info to dup this bug now?

Flags: needinfo?(gsvelto)

Yes, this is definitely bug 1581121.

Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(gsvelto)
Resolution: --- → DUPLICATE
Duplicate of bug: 1581121
Flags: needinfo?(nhnguyen)
You need to log in before you can comment on or make changes to this bug.