Closed Bug 1592106 Opened 2 years ago Closed 1 year ago

Do JSScript::fullyInitFromEmitter on the main thread to avoid having to create the ParserRealm

Categories

(Core :: JavaScript Engine, task, P2)

task

Tracking

()

RESOLVED DUPLICATE of bug 1662102

People

(Reporter: mgaudet, Unassigned)

References

Details

Once all of our GC object allocation is centralized in JSScript::fullyInitFromEmitter, we should be able to move that step on to the main thread.

At that point we should be allocating all our objects in their destination realm, which will allow us to subsequently remove the parse realm, and mergeRealms code.

Priority: -- → P2
Depends on: 1599858
Depends on: 1607854
Blocks: 1625591
Depends on: 1632260
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → DUPLICATE
Duplicate of bug: stencil-mvp
You need to log in before you can comment on or make changes to this bug.