Closed Bug 1592324 Opened 1 year ago Closed 7 months ago

Always show a button to go to AMO in extension/theme list views

Categories

(Toolkit :: Add-ons Manager, enhancement, P3)

70 Branch
enhancement

Tracking

()

RESOLVED FIXED
mozilla76
Tracking Status
firefox76 --- fixed

People

(Reporter: bugzilla, Assigned: gaurijove, Mentored)

Details

Attachments

(3 files)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Steps to reproduce:

I tried to find a nice theme

Actual results:

i went to the about:addons and looked at the suggestions. I did not find anything I liked. I wanted to check out more options but did not have anything specific in mind

Expected results:

There should have been a button or link labelled something like [more] in the "Themes" section of about:addons.

This issue also applies if a user can't remember the name of an extension they wish to install. Therefore, I think this is bad UX and should be changed.

(I can't be the only person who has an easier time remembering icons rather than names)

Severity: normal → minor
Component: Untriaged → Preferences
OS: Unspecified → All
Hardware: Unspecified → All
Severity: minor → normal
Component: Preferences → Add-ons Manager
Keywords: dupeme
Product: Firefox → Toolkit

There's a button at the bottom of the Recommendations tab, but we should likely have it on the Extensions and Themes tabs too.

The templates related to this button are in the aboutaddons.html file [1]. Searching for the template names should find any relevant code in aboutaddons.js.

If someone is looking to work on this I'm happy to answer any questions you may have.

[1] https://searchfox.org/mozilla-central/rev/ce02064d8afc8673cef83c92896ee873bd35e7ae/toolkit/mozapps/extensions/content/aboutaddons.html#250-294

Mentor: mstriemer
Priority: -- → P3
Summary: No link/discoverability from about:addons to https://addons.mozilla.org/ → Always show a button to go to AMO in extension/theme list views

Hi I would I like to work on this.

Assignee: nobody → gaurijove
Attached image After the fix

Added the button on the extensions page.

Attached image After the fix

Added the button on the themes page.

Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/75c75ac98d86
Add button to extensions and themes page. r=mstriemer
Flags: needinfo?(mstriemer)
Attachment #9132506 - Attachment description: Bug 1592324- Add button to extensions and themes page. r=johannh → Bug 1592324 - Add button to extensions and themes page. r=mstriemer
Pushed by mstriemer@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8f4d397702a0
Add button to extensions and themes page. r=mstriemer
Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla76

Nice! Thank you, Jayati! 🏅

You need to log in before you can comment on or make changes to this bug.