Closed Bug 1592720 Opened 1 year ago Closed 1 year ago

Enable WatchPoints in all channels

Categories

(DevTools :: Debugger, task, P1)

task

Tracking

(relnote-firefox 72+, firefox72+ fixed, firefox73 fixed)

RESOLVED FIXED
Firefox 73
Tracking Status
relnote-firefox --- 72+
firefox72 + fixed
firefox73 --- fixed

People

(Reporter: Honza, Assigned: Honza)

References

(Blocks 1 open bug)

Details

(Keywords: dev-doc-complete)

Attachments

(1 file)

Enable WatchPoints in all channels as soon as ready.

Honza

Priority: -- → P3

Once it ships, it should be mentioned in the release notes.

Sebastian

Keywords: dev-doc-needed
Assignee: nobody → odvarko

QA testing looks good so, we can enable on all channels.

Testing on beta in progress and if good, we can uplift next week

Honza

Pushed by jodvarko@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d83253521421
Enable WatchPoints in all channels r=jlast
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 73

If you're intending to ship this in 72, could you request uplift? From comments in email and from the Trello card at https://trello.com/c/bAgF83UW/835-debugger-watchpoints looks like 72 is the goal.

Flags: needinfo?(odvarko)

Comment on attachment 9115414 [details]
Bug 1592720 - Enable WatchPoints in all channels

Beta/Release Uplift Approval Request

  • User impact if declined: Developers won't have the feature enabled by default.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The feature went through QA testing, all look good.
  • String changes made/needed:
Flags: needinfo?(odvarko)
Attachment #9115414 - Flags: approval-mozilla-beta?

Comment on attachment 9115414 [details]
Bug 1592720 - Enable WatchPoints in all channels

turn watchpoints on for 72 beta and release, approved for 72.0b8

Attachment #9115414 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Changing the priority to p1 as the bug is tracked by a release manager for the current beta.
See What Do You Triage for more information

Priority: P3 → P1
Depends on: 1592718

So this was uplifted to 72, and we have covered the new watchpoint UI stuff on MDN and in the 72 rel notes:

Therefore I don't think there's anything else for us to do here?

Let me know if I've got this wrong, and i'll be happy to do any further required updates. Thanks!

Looks great to me, thanks Chris!

Honza

You need to log in before you can comment on or make changes to this bug.