Closed Bug 1592839 Opened 10 months ago Closed 3 months ago

Intermittent devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js | Test timed out -

Categories

(DevTools :: Debugger, defect, P5)

defect

Tracking

(firefox77 fixed)

RESOLVED FIXED
Firefox 77
Tracking Status
firefox77 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: rmaries)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: intermittent-failure, Whiteboard: [retriggered][stockwell fixed:patch])

Attachments

(2 files)

Summary: Intermittent TV devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js | Test timed out - → Intermittent devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js | Test timed out -
Status: NEW → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED

Recent failure log: https://treeherder.mozilla.org/logviewer.html#/jobs?job_id=283543088&repo=mozilla-central&lineNumber=2221

[task 2020-01-05T23:52:31.700Z] 23:52:31 INFO - TEST-PASS | devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js | a new breakpoint was created -
[task 2020-01-05T23:52:31.701Z] 23:52:31 INFO - Buffered messages logged at 23:51:01
[task 2020-01-05T23:52:31.701Z] 23:52:31 INFO - Longer timeout required, waiting longer... Remaining timeouts: 2
[task 2020-01-05T23:52:31.701Z] 23:52:31 INFO - Buffered messages logged at 23:51:46
[task 2020-01-05T23:52:31.701Z] 23:52:31 INFO - Longer timeout required, waiting longer... Remaining timeouts: 1
[task 2020-01-05T23:52:31.701Z] 23:52:31 INFO - Buffered messages finished
[task 2020-01-05T23:52:31.701Z] 23:52:31 INFO - TEST-UNEXPECTED-FAIL | devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js | Test timed out -
[task 2020-01-05T23:52:31.714Z] 23:52:31 INFO - Removing tab.
[task 2020-01-05T23:52:31.714Z] 23:52:31 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2020-01-05T23:52:31.726Z] 23:52:31 INFO - Got event: 'TabClose' on [object XULElement].
[task 2020-01-05T23:52:31.738Z] 23:52:31 INFO - Tab removed and finished closing
[task 2020-01-05T23:52:31.996Z] 23:52:31 INFO - Removing tab.
[task 2020-01-05T23:52:31.996Z] 23:52:31 INFO - Waiting for event: 'TabClose' on [object XULElement].
[task 2020-01-05T23:52:31.998Z] 23:52:31 INFO - Got event: 'TabClose' on [object XULElement].
[task 2020-01-05T23:52:32.010Z] 23:52:32 INFO - Tab removed and finished closing

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Flags: needinfo?(jlaster)
Whiteboard: [stockwell needswork:owner]
Flags: needinfo?(jlaster) → needinfo?(jdescottes)
Regressed by: 1603190
Whiteboard: [stockwell needswork:owner] → [retriggered][stockwell needswork:owner]

FYI, it fails locally via
$ ./mach mochitest devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js --repeat 10

And timesout on this addBreakpoint call
(I don't know if that's the same failure as we see on try?)

I see this intermittent a lot in bug 1593937 try. Is it already permafailing, or is this bug making it permanent?
Locally I don't see much difference, it seems to fail the same with/without these new patches.

https://treeherder.mozilla.org/#/jobs?repo=try&revision=b12b72343a92541ef926079382be3507b819b276

Looking at this today.

(In reply to Alexandre Poirot [:ochameau] from comment #33)

FYI, it fails locally via
$ ./mach mochitest devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js --repeat 10

And timesout on this addBreakpoint call
(I don't know if that's the same failure as we see on try?)

Yes this is the same failure (although your link points to another spot, because it was not using a permalink and the test was shuffled a bit since https://bugzilla.mozilla.org/show_bug.cgi?id=1633624) https://searchfox.org/mozilla-central/rev/9b7a256fa0d1776a551535a4365e2e4d57b9be6f/devtools/client/debugger/test/mochitest/browser_dbg-breakpoints-reloading.js#56

await addBreakpoint(dbg, "doc-scripts.html", 27);

However I can't repro locally, and I didn't get a permafail on this test on try before enabling the pref.

The initial patch from Brian had a weird modification to the test document for this test:
https://phabricator.services.mozilla.com/D59481?id=264673#change-7AKksnnelhza

diff --git a/devtools/client/debugger/test/mochitest/examples/doc-scripts.html b/devtools/client/debugger/test/mochitest/examples/doc-scripts.html
--- a/devtools/client/debugger/test/mochitest/examples/doc-scripts.html
+++ b/devtools/client/debugger/test/mochitest/examples/doc-scripts.html
@@ -25,6 +25,7 @@
       // This is a second inline script element whose breakpoints won't be
       // known until after the script element has been added.
       var x = 3;
+      inline_script2 = function () { var x = 5; };
     </script>
   </body>
 </html>

This was adding a new line below the line where we try to set a breakpoint.
Again I didn't see any difference with or without this on my try pushes so I removed it.
We can try adding this change again to see if it helps, although that's probably just hiding a real bug.

I will also see if disabling the pref only for this test helps.

Flags: needinfo?(jdescottes)

I didn't get a permafail on this test on try before enabling the pref.

Looking back at my older try pushes, the test actually failed on Linux debug fission when removing the test change.
But since this was already an intermittent, I ignored it.

This means it's very likely that changing the test document will "fix" the permafail on linux debug.

Assignee: nobody → rmaries

I've created a disabling patch since this bug is on our disable-recommended filter. Julian, should we land it?

Flags: needinfo?(jdescottes)

(In reply to Razvan Maries from comment #41)

I've created a disabling patch since this bug is on our disable-recommended filter. Julian, should we land it?

I have two patches that seem to fix the linux debug fission permafail issue.

If you don't mind waiting for a couple hours until I can find which one also has the best impact on other platforms, I would prefer landing one of those rather than disabling. But since it's high frequency, I'll leave it up to you.

Flags: needinfo?(jdescottes)

Adding this new inline scripts avoids frequent timeouts for browser_dbg-breakpoints-reloading.js

This patch seems to yield the best results, I don't really understand why though.

Adding more logs, the addBreakpoint call times out on await onBreakpoint; at https://searchfox.org/mozilla-central/rev/7fd1c1c34923ece7ad8c822bee062dd0491d64dc/devtools/client/debugger/test/mochitest/helpers.js#884, which is linked to a waitForDispatch(dbg, "SET_BREAKPOINT");.

And from the debugger logs, we can see that the last action logged is [ACTION] ADD_BREAKPOINT_POSITIONS - {}.

Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered]
Pushed by jdescottes@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/06f8636f26bc
Add new inline script in test document doc-scripts.html r=Honza
Status: REOPENED → RESOLVED
Closed: 7 months ago3 months ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 77
Whiteboard: [retriggered][stockwell disable-recommended] → [retriggered][stockwell fixed:patch]
You need to log in before you can comment on or make changes to this bug.